aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-cryptography_1.1.bb
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2015-11-23 12:13:47 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:33:06 +0100
commit06f04adf4b6572f79839240bdd6e0b0f389bbc08 (patch)
treee03e40b6d324090e3313c6e224f2b3c54c08602b /meta-python/recipes-devtools/python/python-cryptography_1.1.bb
parent2463e39c449cb3431e28a2a1ed5c31f778bf47bc (diff)
downloadmeta-openembedded-contrib-06f04adf4b6572f79839240bdd6e0b0f389bbc08.tar.gz
python-cryptography, python-cryptography-vectors: uprev
Pick up many fixes and enhancements made since 0.8.1 was released. See: https://github.com/pyca/cryptography/blob/master/CHANGELOG.rst The uprev requires an uprev of pyasn1 and also pulls in two new packages idna and ipaddress. The idna software has 3 licenses, one of which is the 'Unicode' license: http://www.unicode.org/copyright.html Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-cryptography_1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-cryptography_1.1.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-cryptography_1.1.bb b/meta-python/recipes-devtools/python/python-cryptography_1.1.bb
new file mode 100644
index 0000000000..b3eee0309c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-cryptography_1.1.bb
@@ -0,0 +1,53 @@
+SUMMARY = "Provides cryptographic recipes and primitives to Python developers"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0 | BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4"
+DEPENDS += " python-cffi-native python-cffi python-enum34 python-six python-pyasn1"
+SRCNAME = "cryptography"
+
+SRC_URI = "https://pypi.python.org/packages/source/c/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ file://run-ptest \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+SRC_URI[md5sum] = "dd06da41535184f48f2c8e8b74dd570f"
+SRC_URI[sha256sum] = "059bc6428b1d0e2317f505698602642f1d8dda5b120ec573a59a430d8cb7a32d"
+
+inherit pypi
+
+RDEPENDS_${PN} = "\
+ python-pyasn1\
+ python-six\
+ python-cffi\
+ python-enum34\
+ python-setuptools\
+ python-pycparser\
+ python-subprocess\
+ python-threading\
+ python-numbers\
+ python-contextlib\
+ python-ipaddress\
+ python-pyasn1\
+ python-idna\
+"
+
+RDEPENDS_${PN}-ptest = "\
+ ${PN}\
+ python-pytest\
+ python-pretend\
+ python-iso8601\
+ python-cryptography-vectors\
+"
+
+inherit ptest
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+ install -d ${D}${PTEST_PATH}/tests/hazmat
+ cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
+}
+
+FILES_${PN}-dbg += " \
+ ${libdir}/python2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
+ " \ No newline at end of file