aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-04 16:43:51 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-06 06:32:14 -0800
commita9ebc44571dcfaaddc6255b07ed0141ba40f6b69 (patch)
tree020f4f8056c0f0951e9e3f1fbe67f31a2e341a32 /meta-oe
parent3fc72e6efd71b414a833d4e7f4fb2c5e0b4f8189 (diff)
downloadmeta-openembedded-contrib-a9ebc44571dcfaaddc6255b07ed0141ba40f6b69.tar.gz
iwd: Fix build race during documentation build
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch40
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_1.0.bb4
2 files changed, 43 insertions, 1 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch b/meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch
new file mode 100644
index 0000000000..93ef007f86
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch
@@ -0,0 +1,40 @@
+From f2a2b9f445ab1e31fbb27a74744e9a2ededfce17 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 4 Nov 2019 16:38:04 -0800
+Subject: [PATCH] Makefile.am: Avoid redirection of input and output files
+
+Ensure that directory is created before its written to
+
+This can cause a build race in a highly parallelised build where a directory is not yet created but
+output file is being written using redirection e.g.
+
+rst2man.py --strict --no-raw --no-generator --no-datestamp < ../git/monitor/iwmon.rst > monitor/iwmon.1
+/bin/sh: monitor/iwmon.1: No such file or directory
+make[1]: *** [Makefile:3544: monitor/iwmon.1] Error 1
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Makefile.am | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 823b7d02..1bd0005c 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -626,8 +626,9 @@ SED_PROCESS = $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(SED) \
+ < $< > $@
+
+ if RUN_RST2MAN
+-RST2MAN_PROCESS = $(AM_V_GEN)$(RST2MAN) --strict --no-raw --no-generator \
+- --no-datestamp < $< > $@
++RST2MAN_PROCESS = $(AM_V_GEN)$(MKDIR_P) $(dir $@) && \
++ $(AM_V_GEN)$(RST2MAN) --strict --no-raw \
++ --no-generator --no-datestamp $< $@
+ else
+ RST2MAN_PROCESS = $(AM_V_GEN)test -f $@ || \
+ { echo "Generated manual page $@ does not exist"; false; }
+--
+2.24.0
+
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.0.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.0.bb
index 81260cc020..d11e0d4ae3 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd_1.0.bb
+++ b/meta-oe/recipes-connectivity/iwd/iwd_1.0.bb
@@ -6,7 +6,9 @@ inherit autotools pkgconfig systemd python3native
DEPENDS = "ell readline dbus python3-docutils-native"
-SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git"
+SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
+ file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \
+ "
SRCREV = "971e1d2038a203ad43bd2278a811a9e5ec8d52db"
S = "${WORKDIR}/git"