aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-01 18:00:25 -0700
committerKhem Raj <raj.khem@gmail.com>2019-11-01 18:02:09 -0700
commit31693faa26c9b4d3e49532cd772471b26c8c996a (patch)
tree8404cb4dbb0fde738746deb8bf7b4f604a3ad578 /meta-oe
parent39d717de36f6bc2bc99b0fc4c18bb7fa9e611d13 (diff)
downloadmeta-openembedded-contrib-31693faa26c9b4d3e49532cd772471b26c8c996a.tar.gz
poco: Fix build on risc-v
Patch fixes following error TOPDIR/build/tmp/work/riscv64-yoe-linux-musl/poco/1.9.4-r0/git/Foundation/src/utils.h:76:2: error: Target architecture was not detected as supported by Double-Conversion. ^ 1 error generated. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/poco/poco/0001-riscv-Enable-double-operations-when-using-double-flo.patch28
-rw-r--r--meta-oe/recipes-support/poco/poco_1.9.4.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/poco/poco/0001-riscv-Enable-double-operations-when-using-double-flo.patch b/meta-oe/recipes-support/poco/poco/0001-riscv-Enable-double-operations-when-using-double-flo.patch
new file mode 100644
index 0000000000..c0de32dafe
--- /dev/null
+++ b/meta-oe/recipes-support/poco/poco/0001-riscv-Enable-double-operations-when-using-double-flo.patch
@@ -0,0 +1,28 @@
+From 589a5442a841b156a1890bc2d26e7a5103e2f672 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 1 Nov 2019 17:53:50 -0700
+Subject: [PATCH] riscv: Enable double operations when using double float abi
+
+Upstream-Status: Submitted [https://github.com/pocoproject/poco/pull/2825]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ Foundation/src/utils.h | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Foundation/src/utils.h b/Foundation/src/utils.h
+index 69cea1aca..ff7a5c9ce 100644
+--- a/Foundation/src/utils.h
++++ b/Foundation/src/utils.h
+@@ -63,7 +63,8 @@
+ defined(__SH4__) || defined(__alpha__) || \
+ defined(_MIPS_ARCH_MIPS32R2) || \
+ defined(__AARCH64EL__) || \
+- defined(nios2) || defined(__nios2) || defined(__nios2__)
++ defined(nios2) || defined(__nios2) || defined(__nios2__) || \
++ (defined(__riscv) && defined(__riscv_float_abi_double))
+ #define DOUBLE_CONVERSION_CORRECT_DOUBLE_OPERATIONS 1
+ #elif defined(_M_IX86) || defined(__i386__) || defined(__i386)
+ #if defined(_WIN32)
+--
+2.23.0
+
diff --git a/meta-oe/recipes-support/poco/poco_1.9.4.bb b/meta-oe/recipes-support/poco/poco_1.9.4.bb
index 212abe29bb..c854481de3 100644
--- a/meta-oe/recipes-support/poco/poco_1.9.4.bb
+++ b/meta-oe/recipes-support/poco/poco_1.9.4.bb
@@ -11,6 +11,7 @@ DEPENDS = "libpcre zlib"
SRC_URI = " \
git://github.com/pocoproject/poco.git;branch=poco-${PV} \
file://0001-Don-t-try-to-install-non-existing-Encodings-testsuit.patch \
+ file://0001-riscv-Enable-double-operations-when-using-double-flo.patch \
file://run-ptest \
"
SRCREV = "b95393dcc3640807838e8323b4e600e54d2e8116"