aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/gmock/gmock/cmake-gmock.pc.in-Add-pkg-config-support.patch
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-12-15 06:11:31 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:23:24 +0100
commit1e2491d12520d767e0e5687a9b15819fe0b6ff27 (patch)
treee0c90ec74255845041012d4087b0a11af0c8d816 /meta-oe/recipes-test/gmock/gmock/cmake-gmock.pc.in-Add-pkg-config-support.patch
parentc4e9e1c9acecc9b46a9ec6fe2c123c223e9961e8 (diff)
downloadmeta-openembedded-contrib-1e2491d12520d767e0e5687a9b15819fe0b6ff27.tar.gz
gtest, gmock: update 1.7.0 -> 1.8.0
Starting from the 1.8.0 release, GoogleTest and GoogleMock are maintained in the same repository and released together. Update the gtest recipe to PROVIDE gmock (and drop the gmock recipe). Patches to add CMake install rules have been dropped (now supported upstream). https://github.com/google/googletest/commit/98d988deac06637364f6cd41c45c3db4a8a0b6bc https://github.com/google/googletest/commit/7c8ac4886a7ad513430d132c446a93c6d395345a Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/gmock/gmock/cmake-gmock.pc.in-Add-pkg-config-support.patch')
-rw-r--r--meta-oe/recipes-test/gmock/gmock/cmake-gmock.pc.in-Add-pkg-config-support.patch56
1 files changed, 0 insertions, 56 deletions
diff --git a/meta-oe/recipes-test/gmock/gmock/cmake-gmock.pc.in-Add-pkg-config-support.patch b/meta-oe/recipes-test/gmock/gmock/cmake-gmock.pc.in-Add-pkg-config-support.patch
deleted file mode 100644
index 8ffe1a6a1e..0000000000
--- a/meta-oe/recipes-test/gmock/gmock/cmake-gmock.pc.in-Add-pkg-config-support.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-From 45661183a7c78d8c4f75adcf53c6ddd663dc8b2d Mon Sep 17 00:00:00 2001
-From: Mario Domenech Goulart <mario@ossystems.com.br>
-Date: Mon, 20 Oct 2014 17:12:58 -0200
-Subject: [PATCH] CMakeLists, gmock.pc.in: Add pkg-config support
-Organization: O.S. Systems Software LTDA.
-
-Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br>
----
- CMakeLists.txt | 7 ++++++-
- gmock.pc.in | 9 +++++++++
- 2 files changed, 15 insertions(+), 1 deletion(-)
- create mode 100644 gmock.pc.in
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 90e797a..98fd824 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -27,6 +27,9 @@ if (COMMAND pre_project_set_up_hermetic_build)
- pre_project_set_up_hermetic_build()
- endif()
-
-+# pkg-config support
-+configure_file("gmock.pc.in" "gmock.pc" @ONLY)
-+
- ########################################################################
- #
- # Project-wide settings
-@@ -87,7 +90,9 @@ cxx_library(gmock_main
-
- install(TARGETS gmock DESTINATION ${CMAKE_INSTALL_LIBDIR})
- install(TARGETS gmock_main DESTINATION ${CMAKE_INSTALL_LIBDIR})
--
-+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/gmock.pc"
-+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig/"
-+)
- ########################################################################
- #
- # Google Mock's own tests.
-diff --git a/gmock.pc.in b/gmock.pc.in
-new file mode 100644
-index 0000000..08ad8d2
---- /dev/null
-+++ b/gmock.pc.in
-@@ -0,0 +1,9 @@
-+Name: libgmock
-+Version: 1.7.0
-+Description: Google's framework for writing C++ tests on a variety of platforms
-+
-+prefix=@CMAKE_INSTALL_PREFIX@
-+includedir=${prefix}/include
-+libdir=${prefix}/lib
-+Cflags:-I${includedir}/gmock
-+Libs: -L${libdir} -lgmock -lgmock_main
---
-1.9.1
-