aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2017-01-25 15:31:59 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-13 18:43:23 +0100
commitebef44963866d3231ccfe79d66d21c96ca0b4113 (patch)
tree3eae06de942ade83dfaac41f506f32d77b5a13e7 /meta-oe/recipes-support
parente79566f51dde46145cfdc3732a6e1464ff27f4f3 (diff)
downloadmeta-openembedded-contrib-ebef44963866d3231ccfe79d66d21c96ca0b4113.tar.gz
remove some more True options to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls. Fix a small number of cases not addressed by the original patch: http://git.openembedded.org/meta-openembedded/commit/?id=efd3696e70a6603f1a45faa4a172433514f0a487 Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/nano/nano.inc2
-rw-r--r--meta-oe/recipes-support/openldap/openldap_2.4.44.bb2
-rw-r--r--meta-oe/recipes-support/vim/vim_8.0.0022.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/nano/nano.inc b/meta-oe/recipes-support/nano/nano.inc
index 8a1d71f642..22f0fb2a0a 100644
--- a/meta-oe/recipes-support/nano/nano.inc
+++ b/meta-oe/recipes-support/nano/nano.inc
@@ -8,7 +8,7 @@ SECTION = "console/utils"
DEPENDS = "ncurses file"
RDEPENDS_${PN} = "ncurses-terminfo"
-PV_MAJOR = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
+PV_MAJOR = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
SRC_URI = "https://nano-editor.org/dist/v${PV_MAJOR}/nano-${PV}.tar.xz"
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.44.bb b/meta-oe/recipes-support/openldap/openldap_2.4.44.bb
index 645a5179c7..e8e0c857b5 100644
--- a/meta-oe/recipes-support/openldap/openldap_2.4.44.bb
+++ b/meta-oe/recipes-support/openldap/openldap_2.4.44.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=c933fba6d89fda89f58df1e086e3f2e7 \
"
SECTION = "libs"
-LDAP_VER = "${@'.'.join(d.getVar('PV',1).split('.')[0:2])}"
+LDAP_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}"
SRC_URI = "ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/${BP}.tgz \
file://openldap-m4-pthread.patch \
diff --git a/meta-oe/recipes-support/vim/vim_8.0.0022.bb b/meta-oe/recipes-support/vim/vim_8.0.0022.bb
index 112ae80a25..126fe61628 100644
--- a/meta-oe/recipes-support/vim/vim_8.0.0022.bb
+++ b/meta-oe/recipes-support/vim/vim_8.0.0022.bb
@@ -14,7 +14,7 @@ SRCREV = "ec68a99464055029c01082762517e97245ddae0c"
S = "${WORKDIR}/git/src"
-VIMDIR = "vim${@d.getVar('PV',1).split('.')[0]}${@d.getVar('PV',1).split('.')[1]}"
+VIMDIR = "vim${@d.getVar('PV').split('.')[0]}${@d.getVar('PV').split('.')[1]}"
inherit autotools update-alternatives
inherit autotools-brokensep