aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-07-19 01:38:38 +0200
committerKhem Raj <raj.khem@gmail.com>2023-07-20 19:08:57 -0700
commit51861886e03e48123c6c3579569b569e1c30ca06 (patch)
tree1ad3acb879573011988d8b856b20d7eb2316c87b /meta-oe/recipes-support
parent21ffd6f33fed7de96941a0cb32eb475d54dc194b (diff)
downloadmeta-openembedded-contrib-51861886e03e48123c6c3579569b569e1c30ca06.tar.gz
libtommath: add recipe for LibTomMath used by dropbear
* When system-libtom PACKAGECONFIG is used, both libtomcrypt and libtommath are used from system and we need a recipes for both. * libtomcrypt was already added to meta-oe in langdale and PACKAGECONFIG was added in dropbear in: https://git.openembedded.org/openembedded-core/commit/?id=b7c2edd2d6ded287d8b34dd047ae84d3fd69d4c6 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/libtommath/libtommath_1.2.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libtommath/libtommath_1.2.0.bb b/meta-oe/recipes-support/libtommath/libtommath_1.2.0.bb
new file mode 100644
index 0000000000..1efccdd843
--- /dev/null
+++ b/meta-oe/recipes-support/libtommath/libtommath_1.2.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "LibTomMath is a number theoretic multiple-precision integer library"
+HOMEPAGE = "https://www.libtom.net/LibTomMath"
+SECTION = "libs"
+LICENSE = "Unlicense"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=23e7e0a32e53a2b1d35f5fd9ef053402"
+
+DEPENDS = "libtool-cross"
+
+SRC_URI = "git://github.com/libtom/libtommath.git;protocol=https;branch=master"
+
+SRCREV = "6ca6898bf37f583c4cc9943441cd60dd69f4b8f2"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "'PREFIX=${prefix}' 'DESTDIR=${D}' 'LIBPATH=${libdir}' 'CFLAGS=${CFLAGS}'"
+
+do_compile() {
+ oe_runmake -f makefile.shared
+}
+
+do_install() {
+ oe_runmake -f makefile.shared install
+}