aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-18 17:15:17 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-24 15:31:50 +0200
commitd98907203cc2653eee1db998e30d129c9c9a063a (patch)
treeaa942bf377f455d06d7120da61acaf85bb80f442 /meta-oe/recipes-support/syslog-ng/syslog-ng.inc
parent1a6e16bcb1145df51b15c19df0d7ef655b683f5e (diff)
downloadmeta-openembedded-contrib-d98907203cc2653eee1db998e30d129c9c9a063a.tar.gz
syslog-ng: Various fixes
* Add PACKAGECONFIG for floating json dependency * Add PACKAGECONFIG for floating tcp-wrappers dependency * Disable mongodb host infection problem * Disable rabbitmq host infection problem * Add patch for dbi host include flags issue (making dbi conditionall really work) * Fix configure automake flags handling Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta-oe/recipes-support/syslog-ng/syslog-ng.inc')
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index 01c9b202cc..3cedba65b2 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -30,6 +30,8 @@ EXTRA_OECONF = " \
--sysconfdir=${sysconfdir}/${BPN} \
--with-module-dir=${libdir}/${BPN} \
--with-sysroot=${STAGING_DIR_HOST} \
+ --with-libmongo-client=no --disable-mongodb \
+ --with-librabbitmq-client=no \
"
PACKAGECONFIG ??= "openssl \
@@ -44,6 +46,8 @@ PACKAGECONFIG[pcre] = "--enable-pcre,--disable-pcre,libpcre,"
PACKAGECONFIG[dbi] = "--enable-sql,--disable-sql,libdbi,"
PACKAGECONFIG[libnet] = "--enable-libnet --with-libnet=${STAGING_BINDIR_CROSS},--disable-libnet,libnet,"
PACKAGECONFIG[smtp] = "--enable-smtp --with-libesmtp=${STAGING_LIBDIR},--disable-smtp,libesmtp,"
+PACKAGECONFIG[json] = "--enable-json,--disable-json,json-c,"
+PACKAGECONFIG[tcp-wrapper] = "--enable-tcp-wrapper,--disable-tcp-wrapper,tcp-wrappers,"
do_configure_prepend() {
eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "s/-D_LARGEFILE_SOURCE//" -e "s/-D_FILE_OFFSET_BITS=64//" ${S}/configure.in', d)}"