aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/libtracefs/libtracefs_1.7.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-06-13 09:39:56 +0800
committerKhem Raj <raj.khem@gmail.com>2023-06-14 09:50:28 -0700
commiteb6de6cd4bd5bbbee34b5d4cd1bf4c18fafbe258 (patch)
tree9bffb50682702c7b7095099ae9a13cf2df8548d7 /meta-oe/recipes-kernel/libtracefs/libtracefs_1.7.0.bb
parent99991e08f5115539711be4a4372d7a87d7c10e3d (diff)
downloadmeta-openembedded-contrib-eb6de6cd4bd5bbbee34b5d4cd1bf4c18fafbe258.tar.gz
libtracefs: upgrade 1.6.4 -> 1.7.0
Changelog: ========== - Fixes to the tests. - Added meson build support (but it is not the default). Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/libtracefs/libtracefs_1.7.0.bb')
-rw-r--r--meta-oe/recipes-kernel/libtracefs/libtracefs_1.7.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/libtracefs/libtracefs_1.7.0.bb b/meta-oe/recipes-kernel/libtracefs/libtracefs_1.7.0.bb
new file mode 100644
index 0000000000..77556d9126
--- /dev/null
+++ b/meta-oe/recipes-kernel/libtracefs/libtracefs_1.7.0.bb
@@ -0,0 +1,22 @@
+# Copyright (C) 2022 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Library to parse raw trace event formats "
+HOMEPAGE = "https://git.kernel.org/pub/scm/libs/libtrace/libtraceevent.git/"
+LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
+LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \
+ file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd"
+SECTION = "libs"
+DEPENDS = "libtraceevent bison-native flex-native"
+
+SRCREV = "aebab37379d0fbadc702d64aca0fe5cf18676404"
+SRC_URI = "git://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git;branch=${BPN};protocol=https \
+ file://0001-makefile-Do-not-preserve-ownership-in-cp-command.patch \
+ "
+S = "${WORKDIR}/git"
+
+inherit pkgconfig
+
+do_install() {
+ oe_runmake install DESTDIR=${D} pkgconfig_dir=${libdir}/pkgconfig
+}