aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/crash
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-17 00:25:56 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-17 12:26:41 -0700
commitc699d2088e4149dc3043542652b6370c51735b6d (patch)
tree8682b2cfba4928b0002bdc2e6b64d164cf808914 /meta-oe/recipes-kernel/crash
parent545f6d08919894295b0ecdf581d8a225f3f741de (diff)
downloadmeta-openembedded-contrib-c699d2088e4149dc3043542652b6370c51735b6d.tar.gz
crash: Fix arm64 build with -fno-common
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/crash')
-rw-r--r--meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch54
-rw-r--r--meta-oe/recipes-kernel/crash/crash_7.2.8.bb1
2 files changed, 55 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch b/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch
new file mode 100644
index 0000000000..c946444388
--- /dev/null
+++ b/meta-oe/recipes-kernel/crash/crash/0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch
@@ -0,0 +1,54 @@
+From 0dddb4e1158705345b7f4f71635d42c89e1b0c8f Mon Sep 17 00:00:00 2001
+From: Dave Anderson <anderson@redhat.com>
+Date: Fri, 31 Jan 2020 17:11:46 -0500
+Subject: [PATCH] Fix for an ARM64 gcc-10 compilation error. Without the
+ patch, the build of the embedded gdb module fails with an error message that
+ indicates "multiple definition of 'tdesc_aarch64'". (anderson@redhat.com)
+
+Upstream-Status: Backport [https://github.com/crash-utility/crash/commit/e770735200c02ac2414c394ea6ec5f7f033efe64]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ gdb-7.6.patch | 30 ++++++++++++++++++++++++++++++
+ 1 file changed, 30 insertions(+)
+
+diff --git a/gdb-7.6.patch b/gdb-7.6.patch
+index f6c311d..f64b55f 100644
+--- a/gdb-7.6.patch
++++ b/gdb-7.6.patch
+@@ -2471,3 +2471,33 @@ diff -up gdb-7.6/opcodes/configure.orig gdb-7.6/opcodes/configure
+ #else
+ # error "!__i386__ && !__x86_64__"
+ #endif
++--- gdb-7.6/gdb/features/aarch64.c.orig
+++++ gdb-7.6/gdb/features/aarch64.c
++@@ -5,7 +5,6 @@
++ #include "osabi.h"
++ #include "target-descriptions.h"
++
++-struct target_desc *tdesc_aarch64;
++ static void
++ initialize_tdesc_aarch64 (void)
++ {
++--- gdb-7.6/gdb/aarch64-linux-nat.c.orig
+++++ gdb-7.6/gdb/aarch64-linux-nat.c
++@@ -37,6 +37,7 @@
++
++ #include "gregset.h"
++
+++extern struct target_desc *tdesc_aarch64;
++ #include "features/aarch64.c"
++
++ /* Defines ps_err_e, struct ps_prochandle. */
++--- gdb-7.6/gdb/aarch64-tdep.c.orig
+++++ gdb-7.6/gdb/aarch64-tdep.c
++@@ -52,6 +52,7 @@
++ #include "gdb_assert.h"
++ #include "vec.h"
++
+++struct target_desc *tdesc_aarch64;
++ #include "features/aarch64.c"
++ #include "features/aarch64-without-fpu.c"
++
+--
+2.28.0
+
diff --git a/meta-oe/recipes-kernel/crash/crash_7.2.8.bb b/meta-oe/recipes-kernel/crash/crash_7.2.8.bb
index 834c92cc46..6e2533635b 100644
--- a/meta-oe/recipes-kernel/crash/crash_7.2.8.bb
+++ b/meta-oe/recipes-kernel/crash/crash_7.2.8.bb
@@ -25,6 +25,7 @@ SRC_URI = "git://github.com/crash-utility/${BPN}.git \
file://remove-unrecognized-gcc-option-m32-for-mips.patch \
file://0002-crash-fix-build-error-unknown-type-name-gdb_fpregset.patch \
file://0003-crash-detect-the-sysroot-s-glibc-header-file.patch \
+ file://0001-Fix-for-an-ARM64-gcc-10-compilation-error.-Without-t.patch \
"
SRCREV = "24f4801f8c8871a2e3e660fe9fa8fdd86bb29876"