aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-01 22:38:58 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-01 23:20:22 -0700
commitfc811eb7e53e5a3d367dccad08558ea946209a3b (patch)
treefa5f7f8496d5d003febe3c66c3d425d494d6b9ab /meta-oe/recipes-graphics
parentd4be801b86229123809ea9fb6829d3f7df83f6bb (diff)
downloadmeta-openembedded-contrib-fc811eb7e53e5a3d367dccad08558ea946209a3b.tar.gz
xdotool: Upgrade to 3.20211022.1 release
Switch to github releases Add missing dep on libxinerama and libxkbcommon Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/xdotool/xdotool_3.20211022.1.bb (renamed from meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb)14
1 files changed, 5 insertions, 9 deletions
diff --git a/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb b/meta-oe/recipes-graphics/xdotool/xdotool_3.20211022.1.bb
index 259c640523..cef82bd348 100644
--- a/meta-oe/recipes-graphics/xdotool/xdotool_1.20100416.2809.bb
+++ b/meta-oe/recipes-graphics/xdotool/xdotool_3.20211022.1.bb
@@ -1,23 +1,19 @@
SUMMARY = "xdotool - command-line X11 automation tool - utilising X11 XTEST interface"
-HOMEPAGE = "http://www.semicomplete.com/projects/xdotool"
+HOMEPAGE = "https://github.com/jordansissel/xdotool"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=2f9cbf7e9401cec8a38666a08851ce6b"
SECTION = "x11"
-DEPENDS = "virtual/libx11 libxtst"
-
-PR = "r1"
+DEPENDS = "virtual/libx11 libxtst libxinerama libxkbcommon"
inherit features_check pkgconfig perlnative
# depends on virtual/libx11
REQUIRED_DISTRO_FEATURES = "x11"
-SRC_URI = "http://semicomplete.googlecode.com/files/xdotool-${PV}.tar.gz"
-SRC_URI[md5sum] = "1d5be641e512c343abfe5f78b39e6f19"
-SRC_URI[sha256sum] = "42d7271fbc796e53db71bb221f311b9ff3c51d90a71c9487a9bd3101ca39894f"
+SRC_URI = "https://github.com/jordansissel/${BPN}/releases/download/v${PV}/${BP}.tar.gz"
+SRC_URI[sha256sum] = "96f0facfde6d78eacad35b91b0f46fecd0b35e474c03e00e30da3fdd345f9ada"
EXTRA_OEMAKE = "PREFIX=${prefix} INSTALLLIB=${libdir} INSTALLMAN=${mandir}"
do_install() {
- oe_runmake -e install DESTDIR=${D} PREFIX=${prefix}
+ oe_runmake install DESTDIR=${D} PREFIX=${prefix}
}
-