aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/ostree
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2023-05-30 15:36:11 +0100
committerKhem Raj <raj.khem@gmail.com>2023-05-30 09:16:06 -0700
commit4ce968fe835bb0c05f7358c5969a18c2191abc96 (patch)
treee2cea9260d0c85f18ea55886caf06990e310544f /meta-oe/recipes-extended/ostree
parente04d5631d3907c90b67f73c50d33fe941a3722be (diff)
downloadmeta-openembedded-contrib-4ce968fe835bb0c05f7358c5969a18c2191abc96.tar.gz
ostree: Add soup3 PACKAGECONFIG, rename soup to soup2
libsoup3 is now supported by ostree, add `soup2` to select the deprecated libsoup2 library and `soup3` for libsoup3. Drop `--disable-glibtest` from PACKAGECONFIG as it does nothing (nor does it appear to have ever done anything). Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/ostree')
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2023.3.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree_2023.3.bb b/meta-oe/recipes-extended/ostree/ostree_2023.3.bb
index 3129dc1140..dc771ce28a 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2023.3.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2023.3.bb
@@ -42,7 +42,7 @@ BUILD_OPTIMIZATION:append = " -O2"
# Package configuration - match ostree defaults, but without rofiles-fuse
# otherwise we introduce a dependendency on meta-filesystems and swap
# soup for curl to avoid bringing in deprecated libsoup2 (though
-# to run ptest requires that you have soup).
+# to run ptest requires that you have soup2 or soup3).
PACKAGECONFIG ??= " \
${@bb.utils.filter('DISTRO_FEATURES', 'selinux smack', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd libmount', '', d)} \
@@ -85,7 +85,8 @@ PACKAGECONFIG[openssl] = "--with-crypto=openssl, , openssl, , , glib gnutls"
PACKAGECONFIG[rofiles-fuse] = "--enable-rofiles-fuse, --disable-rofiles-fuse, fuse3"
PACKAGECONFIG[selinux] = "--with-selinux, --without-selinux, libselinux, bubblewrap"
PACKAGECONFIG[smack] = "--with-smack, --without-smack, smack"
-PACKAGECONFIG[soup] = "--with-soup, --without-soup --disable-glibtest, libsoup-2.4"
+PACKAGECONFIG[soup2] = "--with-soup, --without-soup, libsoup-2.4, , , soup3"
+PACKAGECONFIG[soup3] = "--with-soup3, --without-soup3, libsoup, , , soup2"
PACKAGECONFIG[static] = ""
PACKAGECONFIG[systemd] = "--with-libsystemd --with-systemdsystemunitdir=${systemd_system_unitdir}, --without-libsystemd, systemd"
PACKAGECONFIG[trivial-httpd-cmdline] = "--enable-trivial-httpd-cmdline, --disable-trivial-httpd-cmdline"
@@ -188,7 +189,7 @@ RDEPENDS:${PN}:class-target = " \
#
# Something like this in your local.conf:
#
-# PACKAGECONFIG:append:pn-ostree = " static soup"
+# PACKAGECONFIG:append:pn-ostree = " static soup3"
# KERNEL_EXTRA_FEATURES:append = " features/overlayfs/overlayfs.scc"
# TARGET_CFLAGS:append:pn-busybox = " -static"
#