aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/liblockfile/liblockfile/0001-Makefile.in-add-DESTDIR.patch
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2018-07-19 19:49:31 -0700
committerKhem Raj <raj.khem@gmail.com>2018-07-20 16:14:22 -0700
commitaf574eed885a42146458e3a5e3fd83a172b69fa9 (patch)
tree740980ba771a377949e1ae2d36a49eea1a4443f5 /meta-oe/recipes-extended/liblockfile/liblockfile/0001-Makefile.in-add-DESTDIR.patch
parent625e1e58d006938396c826dc9de56b0d0ca308a9 (diff)
downloadmeta-openembedded-contrib-af574eed885a42146458e3a5e3fd83a172b69fa9.tar.gz
liblockfile: Upgrade to 1.14
* Licence-Update: - Copyright years are updated from 2011 to 2016 - The text as below "On Debian GNU/Linux systems, the complete text of the GNU Lesser General \ Public License can be found in `/usr/share/common-licenses/LGPL-2'. You can \ also find a copy on the GNU website at http://www.gnu.org" updated to "The complete LGPL-2 license is included in the licenses/ directory." * Compared to liblockfile_1.09.orig.tar.gz unpack to ${WORKDIR}/${BPN}-${PV}, liblockfile_1.14.orig.tar.gz unpack to ${WORKDIR}/${BPN} now. Add S = "${WORKDIR}/${BPN}" to fix the gap * Remove two backported patch - install.patch - ldflags.patch * Use DESTDIR instead of the previous ROOT and add patch 0001-Makefile.in-add-DESTDIR.patch to fix below issue: | install -d -m 755 -g root -p /usr/include | install -d -m 755 -g root -p /usr/lib | install -d -m 755 -g root -p /usr/bin | install -m 755 nfslock.so.0.1 /usr/lib | install -d -m 755 -g root -p /usr/share/man/man1 | install: cannot create regular file '/usr/lib/nfslock.so.0.1': Permission denied | Makefile:78: recipe for target 'install_nfslib' failed | make: *** [install_nfslib] Error 1 | make: *** Waiting for unfinished jobs.... | install -d -m 755 -g root -p /usr/share/man/man3 | install -m 644 lockfile.h maillock.h /usr/include | install: cannot create regular file '/usr/include/lockfile.h': Permission denied | install: cannot create regular file '/usr/include/maillock.h': Permission denied | Makefile:64: recipe for target 'install_common' failed | make: *** [install_common] Error 1 * Rework patch: - Rework liblockfile-fix-nfslib-and-soname.patch to 0001-Makefile.in-install-nfslock.so-and-nfslock.so.0.patch as the previous patch partly in upstream - liblockfile-fix-install-so-to-man-dir.patch Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/liblockfile/liblockfile/0001-Makefile.in-add-DESTDIR.patch')
-rw-r--r--meta-oe/recipes-extended/liblockfile/liblockfile/0001-Makefile.in-add-DESTDIR.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/liblockfile/liblockfile/0001-Makefile.in-add-DESTDIR.patch b/meta-oe/recipes-extended/liblockfile/liblockfile/0001-Makefile.in-add-DESTDIR.patch
new file mode 100644
index 0000000000..ea415dd8ba
--- /dev/null
+++ b/meta-oe/recipes-extended/liblockfile/liblockfile/0001-Makefile.in-add-DESTDIR.patch
@@ -0,0 +1,54 @@
+From 67843dabe1177840697839b916fd899218893ec7 Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Thu, 19 Jul 2018 00:25:23 -0700
+Subject: [PATCH] Makefile.in: add DESTDIR
+
+Add DESTDIR to fix below error during do_install
+
+| install -d -m 755 -g root -p /usr/include
+| install -d -m 755 -g root -p /usr/lib
+| install -d -m 755 -g root -p /usr/bin
+| install -m 755 nfslock.so.0.1 /usr/lib
+| install -d -m 755 -g root -p /usr/share/man/man1
+| install: cannot create regular file '/usr/lib/nfslock.so.0.1': Permission denied
+| Makefile:78: recipe for target 'install_nfslib' failed
+| make: *** [install_nfslib] Error 1
+| make: *** Waiting for unfinished jobs....
+| install -d -m 755 -g root -p /usr/share/man/man3
+| install -m 644 lockfile.h maillock.h /usr/include
+| install: cannot create regular file '/usr/include/lockfile.h': Permission denied
+| install: cannot create regular file '/usr/include/maillock.h': Permission denied
+| Makefile:64: recipe for target 'install_common' failed
+| make: *** [install_common] Error 1
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ Makefile.in | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 36a6d23..1e4130e 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -12,11 +12,11 @@ CC = @CC@
+
+ prefix = $(DESTDIR)@prefix@
+ exec_prefix = @exec_prefix@
+-bindir = @bindir@
+-libdir = @libdir@
+-mandir = @mandir@
+-nfslockdir = @nfslockdir@
+-includedir = @includedir@
++bindir = $(DESTDIR)@bindir@
++libdir = $(DESTDIR)@libdir@
++mandir = $(DESTDIR)@mandir@
++nfslockdir = $(DESTDIR)@nfslockdir@
++includedir = $(DESTDIR)@includedir@
+ datarootdir = @datarootdir@
+ MAILGROUP = @MAILGROUP@
+
+--
+2.17.1
+