aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libleak/libleak_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-05 19:00:44 -0800
committerKhem Raj <raj.khem@gmail.com>2021-03-05 19:33:44 -0800
commit12080e4106d3b1dfc313fc1be82d3d6f72eacad0 (patch)
treeb3e764f3a312f8818d924803f79cd31a315655f5 /meta-oe/recipes-extended/libleak/libleak_git.bb
parent355693ce1815fd10a2c7b6d83c865ea0f414bd69 (diff)
downloadmeta-openembedded-contrib-kraj/libleak.tar.gz
libleak: Add recipekraj/libleak
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/libleak/libleak_git.bb')
-rw-r--r--meta-oe/recipes-extended/libleak/libleak_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libleak/libleak_git.bb b/meta-oe/recipes-extended/libleak/libleak_git.bb
new file mode 100644
index 0000000000..b711112710
--- /dev/null
+++ b/meta-oe/recipes-extended/libleak/libleak_git.bb
@@ -0,0 +1,34 @@
+# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "libleak detects memory leak by hooking memory functions (e.g. malloc) by LD_PRELOAD"
+HOMEPAGE = "https://github.com/WuBingzheng/libleak"
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://README.md;beginline=18;endline=21;md5=de4f705f12cdedbe452b2c3524572b03"
+
+DEPENDS += "libbacktrace"
+
+SRC_URI = "gitsm://github.com/WuBingzheng/libleak;protocol=https \
+ file://0001-respect-environment-variables.patch \
+ "
+
+PV = "1.0+git${SRCPV}"
+SRCREV = "ea2bb608ae25701692269a37d39d77e966b887ac"
+
+S = "${WORKDIR}/git"
+
+do_configure () {
+ :
+}
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -Dm 0755 ${B}/libleak.so ${D}${libdir}/libleak.so
+}
+
+FILES_SOLIBSDEV = ""
+
+FILES_${PN} += "${libdir}/libleak.so"