aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-crypto
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-05-04 09:33:06 +0200
committerKhem Raj <raj.khem@gmail.com>2023-05-04 06:47:00 -0700
commit7dfddd70496c606beca45a97e5b9970f273a78db (patch)
tree279600d1974708c935f04e27b2902ca8b9c64a10 /meta-oe/recipes-crypto
parentcefb36b38ea8f0ebc94809c7965e388cb1617e5a (diff)
downloadmeta-openembedded-contrib-7dfddd70496c606beca45a97e5b9970f273a78db.tar.gz
libtomcrypt: pass LIBPATH to fix installed-vs-shipped with multilib
* fixes: ERROR: QA Issue: libtomcrypt: Files/directories were installed but not shipped in any package: /usr/lib /usr/lib/libtomcrypt.so.1.0.1 /usr/lib/libtomcrypt.so.1 /usr/lib/libtomcrypt.so /usr/lib/pkgconfig /usr/lib/pkgconfig/libtomcrypt.pc Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. libtomcrypt: 6 installed and not shipped files. [installed-vs-shipped] when libdir is /usr/lib64 with multilib Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-crypto')
-rw-r--r--meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb b/meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb
index 357fd0ab8d..b144338921 100644
--- a/meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb
+++ b/meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb
@@ -17,5 +17,5 @@ do_compile() {
}
do_install() {
- oe_runmake -f makefile.shared 'PREFIX=${prefix}' 'DESTDIR=${D}' install
+ oe_runmake -f makefile.shared 'PREFIX=${prefix}' 'DESTDIR=${D}' 'LIBPATH=${libdir}' install
}