aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-03 10:37:13 -0700
committerKhem Raj <raj.khem@gmail.com>2019-09-03 16:02:03 -0700
commita0cc2d6353672a00e716e7246c4e9ece1e7fedc0 (patch)
treebdeb0cce4f35edb0cb79a9a0fde961c67366efc6 /meta-networking
parent4f831c84a443aafe308d77dfa95a223f7a3f8f06 (diff)
downloadmeta-openembedded-contrib-a0cc2d6353672a00e716e7246c4e9ece1e7fedc0.tar.gz
iscsi-initiator-utils: Inherit pkgconfig and override PKG_CONFIG
PKG_CONFIG is hardcoded to /usr/bin/pkg-config which is not cross compile safe and ends up with build errors especially on hosts where pkgconf is used it ends up with errors like /usr/bin/pkg-config: line 11: exec: pkgconf: not found /usr/bin/pkg-config: line 11: exec: pkgconf: not found Override it to use own native pkg-config which can deal with sysroot correctly Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.0.877.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.0.877.bb b/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.0.877.bb
index 1ba6ef065c..3cef70f5e0 100644
--- a/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.0.877.bb
+++ b/meta-networking/recipes-daemons/iscsi-initiator-utils/iscsi-initiator-utils_2.0.877.bb
@@ -29,7 +29,7 @@ B = "${WORKDIR}/build"
PV .= "+git${SRCPV}"
-inherit update-rc.d systemd autotools
+inherit update-rc.d systemd autotools pkgconfig
EXTRA_OECONF = " \
--target=${TARGET_SYS} \
@@ -42,6 +42,7 @@ EXTRA_OEMAKE = ' \
BASE="${prefix}" \
MANDIR="${mandir}" \
OPTFLAGS="-DNO_SYSTEMD ${CFLAGS}" \
+ PKG_CONFIG="${STAGING_BINDIR_NATIVE}/pkg-config" \
NO_SYSTEMD=1 \
'