aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/snort/snort
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2017-05-24 17:38:53 +0800
committerJoe MacDonald <joe_macdonald@mentor.com>2017-06-28 10:26:16 -0400
commit3491e039312e69907ab841948108f1f33a4eb956 (patch)
tree440843810e03152797b2e5dedf8fbf0567f538e1 /meta-networking/recipes-connectivity/snort/snort
parent27f425bf2c57bdc9e0cd090eeb9d23a7e787ceb1 (diff)
downloadmeta-openembedded-contrib-3491e039312e69907ab841948108f1f33a4eb956.tar.gz
snort: enable static daq
When start snort, it shows error and quit: | --== Initializing Snort ==-- | Initializing Output Plugins! | ERROR: Can't find pcap DAQ! | Fatal Error, Quitting.. Fix by enable static daq for snort and enable static build for daq. snort calls command daq-modules-config which is from daq-native to get required daq static libraries and library path. Add package daq-native and add patch for snort to filter library path out to avoid host contamination issue. Add daq-native's dependency libnet-native too. And daq-native also depends on libpcap-native from layer oe-core. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/snort/snort')
-rw-r--r--meta-networking/recipes-connectivity/snort/snort/fix-host-contamination-when-enable-static-daq.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/snort/snort/fix-host-contamination-when-enable-static-daq.patch b/meta-networking/recipes-connectivity/snort/snort/fix-host-contamination-when-enable-static-daq.patch
new file mode 100644
index 0000000000..2becc06244
--- /dev/null
+++ b/meta-networking/recipes-connectivity/snort/snort/fix-host-contamination-when-enable-static-daq.patch
@@ -0,0 +1,21 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+When enable static daq for snort, it calls to daq-modules-config to get link
+library and library path. Library path is useless for oe and cause host
+contamination issue. So filter it.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+---
+diff --git a/configure.in b/configure.in
+index fded45b..a247bb9 100644
+--- a/configure.in
++++ b/configure.in
+@@ -658,7 +658,7 @@ fi
+
+ if test "x$enable_static_daq" = "xyes"; then
+ LDAQ=""
+- LIBS="${LIBS} `daq-modules-config --static --libs`"
++ LIBS="${LIBS} `daq-modules-config --static --libs | sed 's#-L[^ ]*##g'`"
+ AC_CHECK_LIB([daq_static], [daq_load_modules],
+ [LIBS="-ldaq_static ${LIBS}"], [LDAQ="no"], [ ])
+