aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/cannelloni
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-23 10:41:02 -0800
committerKhem Raj <raj.khem@gmail.com>2019-12-23 15:03:15 -0800
commit04b8b3916357537372a6e4aa016eda92b6d3d125 (patch)
tree875cb9a132e7aad090d313c1e2bc43415c3cb17a /meta-networking/recipes-connectivity/cannelloni
parenteacca37308b62d79e4342daaea635492c954a6cd (diff)
downloadmeta-openembedded-contrib-04b8b3916357537372a6e4aa016eda92b6d3d125.tar.gz
cannelloni: Include stdexcept for runtime_error
Fixes error: 'runtime_error' is not a member of 'std' throw std::runtime_error("Allocation error."); ^~~~~~~~~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-connectivity/cannelloni')
-rw-r--r--meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch32
-rw-r--r--meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch
new file mode 100644
index 0000000000..55f28dd672
--- /dev/null
+++ b/meta-networking/recipes-connectivity/cannelloni/cannelloni/0002-include-missing-stdexcept-for-runtime_error.patch
@@ -0,0 +1,32 @@
+From 1788762863cd1f657697575f6e73a22e661ccb43 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 23 Dec 2019 10:32:54 -0800
+Subject: [PATCH 2/2] include missing <stdexcept> for runtime_error
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes
+error: ‘runtime_error’ is not a member of ‘std’
+
+Upstream-Status: Submitted [https://github.com/mguentner/cannelloni/pull/22]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ parser.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/parser.cpp b/parser.cpp
+index 4afb9e0..5bcdbde 100644
+--- a/parser.cpp
++++ b/parser.cpp
+@@ -2,6 +2,7 @@
+
+ #include <arpa/inet.h>
+ #include <string.h>
++#include <stdexcept>
+
+ void parseFrames(uint16_t len, const uint8_t* buffer, std::function<canfd_frame*()> frameAllocator,
+ std::function<void(canfd_frame*, bool)> frameReceiver)
+--
+2.24.1
+
diff --git a/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb b/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb
index cd893afb37..d4a62bd92d 100644
--- a/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb
+++ b/meta-networking/recipes-connectivity/cannelloni/cannelloni_git.bb
@@ -4,6 +4,7 @@ LICENSE = "GPLv2"
SRC_URI = "git://github.com/mguentner/cannelloni.git;protocol=https \
file://0001-Use-GNUInstallDirs-instead-of-hard-coding-paths.patch \
+ file://0002-include-missing-stdexcept-for-runtime_error.patch \
"
SRCREV = "82aa49b417b96fe46bb3f017ae1bfea928f20f9a"