aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Galbusera <gizero@gmail.com>2016-11-03 10:25:03 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-23 15:24:01 +0100
commit53a6b833df210aff4319dbbfcf8b6516d5a4301b (patch)
treeaf47e4ebe0480f92698fbd41ba6d457a1cb930dd
parent7f27b88ed6ab5a853227b9a68107cc5bfe92f426 (diff)
downloadmeta-openembedded-contrib-53a6b833df210aff4319dbbfcf8b6516d5a4301b.tar.gz
libiio: add recipe
libiio is a C library for interfacing with IIO devices. It abstracts the low-level details of the hardware, and provides a simple yet complete programming interface. This recipe provides the following packages: * libiio: main package with C library * libiio-iiod: user space daemon providing network backend to iio devices * libiio-tests: user space test applications using libiio * libiio-python: python bindings Signed-off-by: Andrea Galbusera <gizero@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/libiio/libiio_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libiio/libiio_git.bb b/meta-oe/recipes-support/libiio/libiio_git.bb
new file mode 100644
index 0000000000..28a1073e24
--- /dev/null
+++ b/meta-oe/recipes-support/libiio/libiio_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Library for interfacing with IIO devices"
+HOMEPAGE = "https://wiki.analog.com/resources/tools-software/linux-software/libiio"
+SECTION = "libs"
+LICENSE = "LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING.txt;md5=7c13b3376cea0ce68d2d2da0a1b3a72c"
+
+SRCREV = "e0fc3845506ccb19ab02e4b1d81cddeeee0805ab"
+PV = "0.7+git${SRCPV}"
+
+SRC_URI = "git://github.com/analogdevicesinc/libiio.git"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "flex-native bison-native avahi libaio libusb1 libxml2"
+
+inherit cmake pythonnative
+
+PACKAGES =+ "${PN}-iiod ${PN}-tests ${PN}-python"
+
+RDEPENDS_${PN}-python = "${PN} python-ctypes python-stringold"
+
+FILES_${PN}-iiod = "${sbindir}/iiod"
+FILES_${PN}-tests = "${bindir}"
+FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"