aboutsummaryrefslogtreecommitdiffstats
path: root/lib/bb/cookerdata.py
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-18 15:14:19 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-19 22:43:48 +0100
commit659ef95c9b8aced3c4ded81c48bcc0fbde4d429f (patch)
treec63666710636bf12d25ef5a491f5d1abbcca4f96 /lib/bb/cookerdata.py
parent5ecd6a671c088f270d5f49093f8da83278fc0aa9 (diff)
downloadbitbake-659ef95c9b8aced3c4ded81c48bcc0fbde4d429f.tar.gz
bitbake: Add explict getVar param for (non) expansion
Rather than just use d.getVar(X), use the more explict d.getVar(X, False) since at some point in the future, having the default of expansion would be nice. This is the first step towards that. This patch was mostly made using the command: sed -e 's:\(getVar([^,()]*\)\s*):\1, False):g' -i `grep -ril getVar *` Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'lib/bb/cookerdata.py')
-rw-r--r--lib/bb/cookerdata.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/lib/bb/cookerdata.py b/lib/bb/cookerdata.py
index 630ee2758..0ca87a094 100644
--- a/lib/bb/cookerdata.py
+++ b/lib/bb/cookerdata.py
@@ -301,15 +301,15 @@ class CookerDataBuilder(object):
# Nomally we only register event handlers at the end of parsing .bb files
# We register any handlers we've found so far here...
- for var in data.getVar('__BBHANDLERS') or []:
- bb.event.register(var, data.getVar(var), (data.getVarFlag(var, "eventmask", True) or "").split())
+ for var in data.getVar('__BBHANDLERS', False) or []:
+ bb.event.register(var, data.getVar(var, False), (data.getVarFlag(var, "eventmask", True) or "").split())
if data.getVar("BB_WORKERCONTEXT", False) is None:
bb.fetch.fetcher_init(data)
bb.codeparser.parser_cache_init(data)
bb.event.fire(bb.event.ConfigParsed(), data)
- if data.getVar("BB_INVALIDCONF") is True:
+ if data.getVar("BB_INVALIDCONF", False) is True:
data.setVar("BB_INVALIDCONF", False)
self.parseConfigurationFiles(self.prefiles, self.postfiles)
return