aboutsummaryrefslogtreecommitdiffstats
path: root/doc/bitbake-user-manual/bitbake-user-manual-metadata.rst
diff options
context:
space:
mode:
authorNicolas Dechesne <nicolas.dechesne@linaro.org>2020-07-30 18:19:08 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-16 18:13:44 +0100
commit35fdc18549607e195d424f554e8d4b74e87fd245 (patch)
tree287ef4bc3a64455d9673f5fe87540fafaff94a37 /doc/bitbake-user-manual/bitbake-user-manual-metadata.rst
parente11d2dd1adbcb35b45d6d0f3a47f8d06caab0b49 (diff)
downloadbitbake-35fdc18549607e195d424f554e8d4b74e87fd245.tar.gz
sphinx: fixes all remaining warnings
This patch fixes a handful of remaining warnings reported by Sphinx. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
Diffstat (limited to 'doc/bitbake-user-manual/bitbake-user-manual-metadata.rst')
-rw-r--r--doc/bitbake-user-manual/bitbake-user-manual-metadata.rst14
1 files changed, 7 insertions, 7 deletions
diff --git a/doc/bitbake-user-manual/bitbake-user-manual-metadata.rst b/doc/bitbake-user-manual/bitbake-user-manual-metadata.rst
index c0eb118eb..c98b3a9e7 100644
--- a/doc/bitbake-user-manual/bitbake-user-manual-metadata.rst
+++ b/doc/bitbake-user-manual/bitbake-user-manual-metadata.rst
@@ -973,7 +973,7 @@ Tasks
Tasks are BitBake execution units that make up the steps that BitBake
can run for a given recipe. Tasks are only supported in recipes and
classes (i.e. in ``.bb`` files and files included or inherited from
-``.bb`` files). By convention, tasks have names that start with "do_".
+``.bb`` files). By convention, tasks have names that start with "do\_".
Promoting a Function to a Task
------------------------------
@@ -987,8 +987,8 @@ task and declare some dependencies: python do_printdate () { import time
print time.strftime('%Y%m%d', time.gmtime()) } addtask printdate after
do_fetch before do_build The first argument to ``addtask`` is the name
of the function to promote to a task. If the name does not start with
-"do_", "do_" is implicitly added, which enforces the convention that all
-task names start with "do_".
+"do\_", "do\_" is implicitly added, which enforces the convention that all
+task names start with "do\_".
In the previous example, the ``do_printdate`` task becomes a dependency
of the ``do_build`` task, which is the default task (i.e. the task run
@@ -1030,7 +1030,7 @@ Additionally, the ``do_printdate`` task becomes dependent upon the
-c
NBSP
task
- command, you can omit the "do_" prefix as part of the task name.
+ command, you can omit the "do\_" prefix as part of the task name.
You might wonder about the practical effects of using ``addtask``
without specifying any dependencies as is done in the following example:
@@ -1714,10 +1714,10 @@ Support for wildcard use in variables varies depending on the context in
which it is used. For example, some variables and file names allow
limited use of wildcards through the "``%``" and "``*``" characters.
Other variables or names support Python's
-```glob`https://docs.python.org/3/library/glob.html syntax,
-```fnmatch`https://docs.python.org/3/library/fnmatch.html#module-fnmatch
+`glob <https://docs.python.org/3/library/glob.html>`_ syntax,
+`fnmatch <https://docs.python.org/3/library/fnmatch.html#module-fnmatch>`_
syntax, or
-```Regular Expression (re)`https://docs.python.org/3/library/re.html#re
+`Regular Expression (re) <https://docs.python.org/3/library/re.html#re>`_
syntax.
For variables that have wildcard suport, the documentation describes