aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2008-09-30 20:28:11 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2008-09-30 20:28:11 +0000
commitd02bbc17c10a8838fb0b86611e94b91bb1e8fb43 (patch)
tree162d61fc75c6fdc76bae0257ddda36b78876173a
parent3c54c982ede38a160299d40599bdcd93e0caeedd (diff)
downloadbitbake-d02bbc17c10a8838fb0b86611e94b91bb1e8fb43.tar.gz
cooker.py: Rename __depends to __base_depends after configuration parsing so we don't recheck the validity of the config files time after time. Also bump the cache revision to match the format change (from poky)
-rw-r--r--ChangeLog2
-rw-r--r--lib/bb/cache.py2
-rw-r--r--lib/bb/cooker.py1
3 files changed, 4 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index c4aa5ba19..a2d0da29e 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -52,6 +52,8 @@ Changes in BitBake 1.8.x:
- Raise an exception if SRCREV == 'INVALID'
- Fix hg fetcher username/password handling and fix crash
- Fix PACKAGES_DYNAMIC handling of packages with '++' in the name
+ - Rename __depends to __base_depends after configuration parsing so we don't
+ recheck the validity of the config files time after time
Changes in BitBake 1.8.10:
- Psyco is available only for x86 - do not use it on other architectures.
diff --git a/lib/bb/cache.py b/lib/bb/cache.py
index bcf393a57..fe38ea0ae 100644
--- a/lib/bb/cache.py
+++ b/lib/bb/cache.py
@@ -39,7 +39,7 @@ except ImportError:
import pickle
bb.msg.note(1, bb.msg.domain.Cache, "Importing cPickle failed. Falling back to a very slow implementation.")
-__cache_version__ = "128"
+__cache_version__ = "129"
class Cache:
"""
diff --git a/lib/bb/cooker.py b/lib/bb/cooker.py
index 1f9bb49e7..8e6acb19f 100644
--- a/lib/bb/cooker.py
+++ b/lib/bb/cooker.py
@@ -579,6 +579,7 @@ class BBCooker:
bb.msg.debug(1, bb.msg.domain.Collection, "collecting .bb files")
(filelist, masked) = self.collect_bbfiles()
+ bb.data.renameVar("__depends", "__base_depends", self.configuration.data)
self.parse_bbfiles(filelist, masked, self.myProgressCallback)
bb.msg.debug(1, bb.msg.domain.Collection, "parsing complete")