summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
Diffstat (limited to 'bin')
-rwxr-xr-xbin/bitbake5
1 files changed, 4 insertions, 1 deletions
diff --git a/bin/bitbake b/bin/bitbake
index 06198c45a..67cc9d594 100755
--- a/bin/bitbake
+++ b/bin/bitbake
@@ -160,7 +160,8 @@ Default BBFILES are the .bb files in the current directory.""")
configuration = BBConfiguration(options)
configuration.pkgs_to_build.extend(args[1:])
- logger.addHandler(event.LogHandler())
+ loghandler = event.LogHandler()
+ logger.addHandler(loghandler)
#server = bb.server.xmlrpc
server = bb.server.none
@@ -186,6 +187,8 @@ Default BBFILES are the .bb files in the current directory.""")
server.BitBakeServerFork(serverinfo, cooker.serve, cooker_logfile)
del cooker
+ logger.removeHandler(loghandler)
+
# Setup a connection to the server (cooker)
serverConnection = server.BitBakeServerConnection(serverinfo)