summaryrefslogtreecommitdiffstats
path: root/contrib/vim/ftdetect/bitbake.vim
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2006-07-10 19:22:06 +0000
committerChris Larson <clarson@kergoth.com>2006-07-10 19:22:06 +0000
commit345c08effd86188cfd12af686153feebdca664ca (patch)
tree3f3c77e1c959294378f61be4abdf3e782dcd9bf6 /contrib/vim/ftdetect/bitbake.vim
parent628e7791d754ad68b810f275bb346e3c04949026 (diff)
downloadbitbake-contrib-345c08effd86188cfd12af686153feebdca664ca.tar.gz
Contrib: update the Vim syntax highlighting to include the 'require' keyword and '.=' and '=.'. Add a Vim ftdetect plugin to properly set the filetype on bitbake files.
Diffstat (limited to 'contrib/vim/ftdetect/bitbake.vim')
-rw-r--r--contrib/vim/ftdetect/bitbake.vim4
1 files changed, 4 insertions, 0 deletions
diff --git a/contrib/vim/ftdetect/bitbake.vim b/contrib/vim/ftdetect/bitbake.vim
new file mode 100644
index 000000000..3882a9a08
--- /dev/null
+++ b/contrib/vim/ftdetect/bitbake.vim
@@ -0,0 +1,4 @@
+au BufNewFile,BufRead *.bb setfiletype bitbake
+au BufNewFile,BufRead *.bbclass setfiletype bitbake
+au BufNewFile,BufRead *.inc setfiletype bitbake
+" au BufNewFile,BufRead *.conf setfiletype bitbake