aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
Diffstat (limited to 'recipes')
-rw-r--r--recipes/iptstate/iptstate.inc19
-rw-r--r--recipes/iptstate/iptstate_2.2.1.bb20
2 files changed, 21 insertions, 18 deletions
diff --git a/recipes/iptstate/iptstate.inc b/recipes/iptstate/iptstate.inc
new file mode 100644
index 0000000000..0988eb1433
--- /dev/null
+++ b/recipes/iptstate/iptstate.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "IPTState is a top-like interface to your netfilter connection-tracking table."
+HOMEPAGE = "http://www.phildev.net/iptstate/"
+SECTION = "console/network"
+LICENSE = "zlib"
+DEPENDS = "ncurses"
+INC_PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/iptstate/iptstate-${PV}.tar.bz2"
+
+#
+# Make it use it's old style proc interface - these should be removed
+# once libnetfilter_conntrack and libnfnetlink are added to OE.
+#
+CPPFLAGS += " -DIPTSTATE_USE_PROC -L${STAGING_LIBDIR}"
+export LIBS = "-lncurses"
+
+do_install () {
+ oe_runmake install SBIN=${D}/${sbindir} MAN=${D}/${mandir}
+}
diff --git a/recipes/iptstate/iptstate_2.2.1.bb b/recipes/iptstate/iptstate_2.2.1.bb
index 40be6eb109..a27f4c22ab 100644
--- a/recipes/iptstate/iptstate_2.2.1.bb
+++ b/recipes/iptstate/iptstate_2.2.1.bb
@@ -1,19 +1,3 @@
-DESCRIPTION = "IPTState is a top-like interface to your netfilter connection-tracking table."
-HOMEPAGE = "http://www.phildev.net/iptstate/"
-SECTION = "console/network"
-LICENSE = "zlib"
-DEPENDS = "ncurses"
-PR = "r0"
+include iptstate.inc
-SRC_URI = "${SOURCEFORGE_MIRROR}/iptstate/iptstate-${PV}.tar.bz2"
-
-#
-# Make it use it's old style proc interface - these should be removed
-# once libnetfilter_conntrack and libnfnetlink are added to OE.
-#
-CPPFLAGS += " -DIPTSTATE_USE_PROC -L${STAGING_LIBDIR}"
-export LIBS = "-lncurses"
-
-do_install () {
- oe_runmake install SBIN=${D}/${sbindir} MAN=${D}/${mandir}
-}
+PR = "${INC_PR}.0"