aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/xfce-base/exo_0.3.105.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/xfce-base/exo_0.3.105.bb')
-rw-r--r--recipes/xfce-base/exo_0.3.105.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/xfce-base/exo_0.3.105.bb b/recipes/xfce-base/exo_0.3.105.bb
new file mode 100644
index 0000000000..ab3b2a22e5
--- /dev/null
+++ b/recipes/xfce-base/exo_0.3.105.bb
@@ -0,0 +1,30 @@
+DESCRIPTION="XFCE extensions and framework library with session management support"
+DEPENDS = "libxfce4util hal liburi-perl-native python-native cairo"
+SECTION = "x11"
+PR = "r1"
+
+inherit xfce46
+
+XFCE_VERSION = "4.6.1"
+
+SRC_URI += " \
+ file://exo-0.3.105-iocharset.patch;patch=1 \
+ file://exo-no-tests.patch;patch=1 \
+ file://configure.patch;patch=1 \
+"
+
+# Note: Python checking is broken
+do_configure_prepend() {
+ sed -i -e s:'`$PKG_CONFIG --variable=defsdir pygtk-2.0`':\"${STAGING_DATADIR}/pygtk/2.0/defs\":g ${S}/configure.in
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/xfce4/ \
+ ${libdir}/python*/site-packages/* \
+ ${prefix}/share/pygtk/2.0/defs/exo-0.3/exo.defs \
+"
+
+FILES_${PN}-dbg += "${libdir}/python*/site-packages/*/.debug/*"