aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/udev/udev_165.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/udev/udev_165.bb')
-rw-r--r--recipes/udev/udev_165.bb27
1 files changed, 7 insertions, 20 deletions
diff --git a/recipes/udev/udev_165.bb b/recipes/udev/udev_165.bb
index f79e549e2e..c50af10b1b 100644
--- a/recipes/udev/udev_165.bb
+++ b/recipes/udev/udev_165.bb
@@ -3,13 +3,13 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
LICENSE = "GPLv2+"
-PR = "r3"
+PR = "r7"
# Untested
DEFAULT_PREFERENCE = "-1"
# Needed for udev-extras
-DEPENDS = "gperf-native usbutils acl glib-2.0"
+DEPENDS = "gperf-native usbutils acl glib-2.0 mtd-utils"
RDEPENDS_${PN} += "module-init-tools-depmod udev-utils"
SRC_URI = "http://www.mirrorservice.org/sites/ftp.kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
@@ -69,7 +69,7 @@ EXTRA_OECONF += " --with-udev-prefix= \
"
INITSCRIPT_NAME = "udev"
-INITSCRIPT_PARAMS = "start 03 S ."
+INITSCRIPT_PARAMS = "start 04 S ."
PACKAGES =+ "libudev libgudev udev-utils"
@@ -87,23 +87,10 @@ FILES_${PN}-dbg += "${usrbindir}/.debug ${usrsbindir}/.debug"
FILES_${PN} += "/lib/udev* ${libdir}/ConsoleKit"
FILES_${PN}-dbg += "/lib/udev/.debug"
+# Package up systemd files
+FILES_${PN} += "${base_libdir}/systemd"
+
RPROVIDES_udev_append = " udev-compat-wrapper"
-RDEPENDS_udev_append_spitz = " udev-compat"
-do_unpack_append_spitz() {
- bb.build.exec_func('do_apply_compat_wrapper', d)
-}
-RDEPENDS_udev_append_akita = " udev-compat"
-do_unpack_append_akita() {
- bb.build.exec_func('do_apply_compat_wrapper', d)
-}
-RDEPENDS_udev_append_c7x0 = " udev-compat"
-do_unpack_append_c7x0() {
- bb.build.exec_func('do_apply_compat_wrapper', d)
-}
-RDEPENDS_udev_append_poodle = " udev-compat"
-do_unpack_append_poodle() {
- bb.build.exec_func('do_apply_compat_wrapper', d)
-}
# Modify init script on platforms that need to boot old kernels:
do_apply_compat_wrapper() {
@@ -172,5 +159,5 @@ pkg_postinst_udev_append() {
else
OPT="-s"
fi
- update-rc.d $OPT udev-cache start 12 S .
+ update-rc.d $OPT udev-cache start 36 S .
}