aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-git/calamari/buggy-gcc-really-no-spe.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/u-boot/u-boot-git/calamari/buggy-gcc-really-no-spe.patch')
-rw-r--r--recipes/u-boot/u-boot-git/calamari/buggy-gcc-really-no-spe.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot-git/calamari/buggy-gcc-really-no-spe.patch b/recipes/u-boot/u-boot-git/calamari/buggy-gcc-really-no-spe.patch
new file mode 100644
index 0000000000..1ae2cb9a4b
--- /dev/null
+++ b/recipes/u-boot/u-boot-git/calamari/buggy-gcc-really-no-spe.patch
@@ -0,0 +1,16 @@
+Index: git/cpu/mpc85xx/config.mk
+===================================================================
+--- git.orig/cpu/mpc85xx/config.mk 2009-10-23 13:15:11.000000000 +0200
++++ git/cpu/mpc85xx/config.mk 2009-10-23 13:17:27.000000000 +0200
+@@ -24,6 +24,11 @@
+ PLATFORM_RELFLAGS += -fPIC -ffixed-r14 -meabi
+
+ PLATFORM_CPPFLAGS += -ffixed-r2 -Wa,-me500 -msoft-float -mno-string
++
++# -mspe=yes is needed to have -mno-spe accepted by a buggy GCC;
++# see "[PATCH,rs6000] make -mno-spe work as expected" on
++# http://gcc.gnu.org/ml/gcc-patches/2008-04/msg00311.html
++PLATFORM_CPPFLAGS +=$(call cc-option,-mspe=yes)
+ PLATFORM_CPPFLAGS +=$(call cc-option,-mno-spe)
+
+ # Use default linker script. Board port can override in board/*/config.mk