aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/u-boot/u-boot-bug_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/u-boot/u-boot-bug_svn.bb')
-rw-r--r--recipes/u-boot/u-boot-bug_svn.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/recipes/u-boot/u-boot-bug_svn.bb b/recipes/u-boot/u-boot-bug_svn.bb
index dffeea1fc5..f104023be5 100644
--- a/recipes/u-boot/u-boot-bug_svn.bb
+++ b/recipes/u-boot/u-boot-bug_svn.bb
@@ -4,7 +4,7 @@ SECTION = "bootloader"
PRIORITY = "optional"
PV = "1.3.2+svnr${SRCPV}"
SRCREV = "8674"
-PR = "r6"
+PR = "r7"
SRC_URI = "\
svn://svn.buglabs.net/bug/branches/R1.4/qa;module=u-boot;proto=svn \
@@ -26,11 +26,9 @@ do_compile () {
do_deploy () {
install -d ${DEPLOY_DIR_IMAGE}
install -m 0644 ${S}/u-boot.bin ${DEPLOY_DIR_IMAGE}/u-boot-${PV}-${PR}.bin
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/u-boot-${PV}-${PR}.bin
ln -sf ${DEPLOY_DIR_IMAGE}/u-boot-${PV}-${PR}.bin ${DEPLOY_DIR_IMAGE}/uboot-latest.bin
-}
-
-do_stage() {
- install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/mkimage
+ package_stagefile_shell ${DEPLOY_DIR_IMAGE}/uboot-latest.bin
}
do_deploy[dirs] = "${S}"