aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ti
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ti')
-rw-r--r--recipes/ti/am-benchmarks_1.3.bb38
-rw-r--r--recipes/ti/gstreamer-ti.inc8
-rw-r--r--recipes/ti/matrix-gui-common.inc4
-rw-r--r--recipes/ti/matrix-gui-common_1.4.bb4
-rw-r--r--recipes/ti/matrix-gui-e.inc4
-rw-r--r--recipes/ti/matrix-gui-e_1.3.bb4
-rw-r--r--recipes/ti/matrix-gui.inc4
-rw-r--r--recipes/ti/matrix-gui_1.3.bb4
-rw-r--r--recipes/ti/matrix-tui.inc11
-rw-r--r--recipes/ti/matrix-tui_1.1.bb4
-rw-r--r--recipes/ti/ti-codecs-omap3530_4.00.00.00.bb4
-rw-r--r--recipes/ti/ti-dmai.inc4
-rw-r--r--recipes/ti/ti-dmai/beagle/0001-DMAI-video_display-Set-the-default-Display-Output-to.patch26
-rw-r--r--recipes/ti/ti-dmai/beagle/0002-DMAI-Auto-detect-V4L2-display-device-node-to-open.patch109
-rw-r--r--recipes/ti/ti-dmai/beagle/0003-DMAI-Disable-display-rotation-to-avoid-problems-due-.patch29
-rw-r--r--recipes/ti/ti-dmai/beagle/0004-DMAI-Use-the-correct-capture-device-node.patch26
-rw-r--r--recipes/ti/ti-dmai_svn.bb2
-rw-r--r--recipes/ti/ti-ipc_1.23.02.27.bb9
-rw-r--r--recipes/ti/ti-msp430-chronos_1.05.00.00.bb2
-rw-r--r--recipes/ti/ti-syslink.inc241
-rw-r--r--recipes/ti/ti-syslink/syslink.pc10
-rw-r--r--recipes/ti/ti-syslink_2.00.00.78.bb8
-rw-r--r--recipes/ti/ti-wifi-utils_git.bb2
23 files changed, 528 insertions, 29 deletions
diff --git a/recipes/ti/am-benchmarks_1.3.bb b/recipes/ti/am-benchmarks_1.3.bb
new file mode 100644
index 0000000000..6070fe8db1
--- /dev/null
+++ b/recipes/ti/am-benchmarks_1.3.bb
@@ -0,0 +1,38 @@
+#NOTE: This package is currently only supported for the Angstrom
+# distribution. Other distributions and toolchains may or
+# may not work.
+
+DESCRIPTION = "AM Benchmarks"
+HOMEPAGE = "https://gforge.ti.com/gf/project/am_benchmarks/"
+LICENSE = "BSD"
+SECTION = "system"
+PRIORITY = "optional"
+
+SRCREV = "66"
+PR = "r2+svnr${SRCPV}"
+
+SRC_URI = "svn://gforge.ti.com/svn/am_benchmarks/;module=trunk;proto=https;user=anonymous;pswd=''"
+
+S = "${WORKDIR}/trunk"
+
+do_configure() {
+ # Find all the objects.mk files for the Release target
+ files=`find ${BASE_PACKAGE_ARCH} -name "objects.mk" | grep Release`
+ for f in $files
+ do
+ sed -i -e 's|LIBS :=|LIBS := ${LDFLAGS} |' $f
+ done
+}
+
+do_compile() {
+ # don't build debug version
+ touch debug
+ export CROSS_COMPILE=${TARGET_PREFIX}
+ export ARCH=${BASE_PACKAGE_ARCH}
+ make release
+}
+
+do_install() {
+ export ARCH=${BASE_PACKAGE_ARCH}
+ make DESTDIR=${D} install
+}
diff --git a/recipes/ti/gstreamer-ti.inc b/recipes/ti/gstreamer-ti.inc
index 8d355e0e93..3d45ebf06d 100644
--- a/recipes/ti/gstreamer-ti.inc
+++ b/recipes/ti/gstreamer-ti.inc
@@ -15,7 +15,7 @@ require ti-paths.inc
require ti-staging.inc
# Rebuild on kernel change since it links statically to ti-dmai, ti-codec-engine, etc
-PR = "r83+${MACHINE_KERNEL_PR}"
+PR = "r84+${MACHINE_KERNEL_PR}"
DEPENDS = "ti-dmai gstreamer gst-plugins-base"
@@ -90,6 +90,12 @@ do_configure_prepend() {
}
do_compile() {
+ # Ugly hack approaching:
+ # due to libtool sysroot support and this recipe being machine specific libtool won't find libs from the regular sysroots
+
+ install -d ${STAGING_LIBDIR}
+ ln -sf ${STAGING_DIR}/${BASE_PACKAGE_ARCH}${HOST_VENDOR}-${HOST_OS}/${libdir}/lib* ${STAGING_LIBDIR} || true
+
# Recent kernel headers warn against inclusion from userspace
for makefile in $(find ${S} -name "Makefile") ; do
sed -i -e s:-Werror::g $makefile
diff --git a/recipes/ti/matrix-gui-common.inc b/recipes/ti/matrix-gui-common.inc
index 0ed72b53fa..7a465495ab 100644
--- a/recipes/ti/matrix-gui-common.inc
+++ b/recipes/ti/matrix-gui-common.inc
@@ -4,7 +4,7 @@ LICENSE = "BSD"
SECTION = "multimedia"
PRIORITY = "optional"
-INC_PR = "r9"
+INC_PR = "r10"
COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x|ti814x)"
@@ -14,7 +14,7 @@ PLATFORM_omapl138 = "omapl138"
PLATFORM_omap3evm = "omap3530"
PLATFORM_dm37x-evm = "dm3730"
PLATFORM_am37x-evm = "am3715"
-PLATFORM_beagleboard = "am3715"
+PLATFORM_beagleboard = "beagleboard"
PLATFORM_ti816x = "ti816x"
PLATFORM_ti814x = "ti814x"
PLATFORM_am180x-evm = "am180x"
diff --git a/recipes/ti/matrix-gui-common_1.4.bb b/recipes/ti/matrix-gui-common_1.4.bb
index 0b4b25b8d1..868f27682f 100644
--- a/recipes/ti/matrix-gui-common_1.4.bb
+++ b/recipes/ti/matrix-gui-common_1.4.bb
@@ -4,5 +4,5 @@ require matrix-gui-common.inc
# prebuilt version in the repository.
RRECOMMENDS_${PN} = "am-sysinfo"
-SRCREV = "257"
-PR = "${INC_PR}.11"
+SRCREV = "275"
+PR = "${INC_PR}.13"
diff --git a/recipes/ti/matrix-gui-e.inc b/recipes/ti/matrix-gui-e.inc
index 7158d90315..b67b6fa356 100644
--- a/recipes/ti/matrix-gui-e.inc
+++ b/recipes/ti/matrix-gui-e.inc
@@ -4,7 +4,7 @@ LICENSE = "BSD"
SECTION = "multimedia"
PRIORITY = "optional"
-INC_PR = "r23"
+INC_PR = "r24"
COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x|ti814x)"
@@ -14,7 +14,7 @@ PLATFORM_omapl138 = "omapl138"
PLATFORM_omap3evm = "omap3530"
PLATFORM_dm37x-evm = "dm3730"
PLATFORM_am37x-evm = "am3715"
-PLATFORM_beagleboard = "am3715"
+PLATFORM_beagleboard = "beagleboard"
PLATFORM_ti816x = "ti816x"
PLATFORM_ti814x = "ti814x"
PLATFORM_am180x-evm = "am180x"
diff --git a/recipes/ti/matrix-gui-e_1.3.bb b/recipes/ti/matrix-gui-e_1.3.bb
index a6eb17fe62..a86d3ffcf9 100644
--- a/recipes/ti/matrix-gui-e_1.3.bb
+++ b/recipes/ti/matrix-gui-e_1.3.bb
@@ -1,5 +1,5 @@
require matrix-gui-e.inc
-SRCREV = "257"
-PR = "${INC_PR}.10"
+SRCREV = "275"
+PR = "${INC_PR}.12"
diff --git a/recipes/ti/matrix-gui.inc b/recipes/ti/matrix-gui.inc
index 3dd0e1042f..e231db27f6 100644
--- a/recipes/ti/matrix-gui.inc
+++ b/recipes/ti/matrix-gui.inc
@@ -4,7 +4,7 @@ LICENSE = "BSD"
SECTION = "multimedia"
PRIORITY = "optional"
-INC_PR = "r21"
+INC_PR = "r22"
COMPATIBLE_MACHINE = "(dm365|omapl138|omap3|ti816x|ti814x)"
@@ -14,7 +14,7 @@ PLATFORM_omapl138 = "omapl138"
PLATFORM_omap3evm = "omap3530"
PLATFORM_dm37x-evm = "dm3730"
PLATFORM_am37x-evm = "am3715"
-PLATFORM_beagleboard = "am3715"
+PLATFORM_beagleboard = "beagleboard"
PLATFORM_ti816x = "ti816x"
PLATFORM_ti814x = "ti814x"
PLATFORM_am180x-evm = "am180x"
diff --git a/recipes/ti/matrix-gui_1.3.bb b/recipes/ti/matrix-gui_1.3.bb
index 51678df28b..c82a32ed9a 100644
--- a/recipes/ti/matrix-gui_1.3.bb
+++ b/recipes/ti/matrix-gui_1.3.bb
@@ -1,4 +1,4 @@
require matrix-gui.inc
-SRCREV = "257"
-PR = "${INC_PR}.6"
+SRCREV = "275"
+PR = "${INC_PR}.8"
diff --git a/recipes/ti/matrix-tui.inc b/recipes/ti/matrix-tui.inc
index 1ad8aa894b..ef89f1fa56 100644
--- a/recipes/ti/matrix-tui.inc
+++ b/recipes/ti/matrix-tui.inc
@@ -9,13 +9,6 @@ INC_PR = "r7"
COMPATIBLE_MACHINE = "(omapl138|omap3)"
-PLATFORM_am37x-evm = "am3715"
-PLATFORM_beagleboard = "am3715"
-PLATFORM_am3517-evm = "am3517"
-PLATFORM_am180x-evm = "am180x"
-PLATFORM_am181x-evm = "am181x"
-PLATFORM_da850-omapl138-evm = "am180x"
-
SRC_URI = "svn://gforge.ti.com/svn/matrix_tui/;module=trunk;proto=https;user=anonymous;pswd='' \
file://init \
"
@@ -28,7 +21,6 @@ S = "${WORKDIR}/trunk"
#INITSCRIPT_PARAMS = "defaults 99"
do_configure() {
- sed -i -e 's:PATH=${LINUX_DEVKIT_PATH}/arm-none-linux-gnueabi:PATH ?= ${LINUX_DEVKIT_PATH}/arm-none-linux-gnueabi:' makefile.init
sed -i -e 's|LIBS :=|LIBS := ${LDFLAGS} |' Release/objects.mk
}
@@ -39,11 +31,12 @@ do_compile() {
export TUI_INCLUDE_PATH=${STAGING_INCDIR}
export XML_INCLUDE_PATH=${STAGING_INCDIR}/libxml2
export TUI_LIB_PATH=${STAGING_LIBDIR}
+ export PLATFORM=${MACHINE}
make release
}
do_install() {
- export PLATFORM=${PLATFORM}
+ export PLATFORM=${MACHINE}
make DESTDIR=${D} install
install -d ${D}${sysconfdir}/init.d/
install -c -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-tui
diff --git a/recipes/ti/matrix-tui_1.1.bb b/recipes/ti/matrix-tui_1.1.bb
index 9814d5fa23..0c2adc0178 100644
--- a/recipes/ti/matrix-tui_1.1.bb
+++ b/recipes/ti/matrix-tui_1.1.bb
@@ -1,4 +1,4 @@
require matrix-tui.inc
-SRCREV = "37"
-PR = "${INC_PR}.4"
+SRCREV = "42"
+PR = "${INC_PR}.5"
diff --git a/recipes/ti/ti-codecs-omap3530_4.00.00.00.bb b/recipes/ti/ti-codecs-omap3530_4.00.00.00.bb
index 4dc912f473..31c047d083 100644
--- a/recipes/ti/ti-codecs-omap3530_4.00.00.00.bb
+++ b/recipes/ti/ti-codecs-omap3530_4.00.00.00.bb
@@ -6,8 +6,9 @@ require ti-paths.inc
require ti-staging.inc
PR="${MACHINE_KERNEL_PR}"
-PR_append = "a"
+PR_append = "b"
+PE = "1"
PV="4_00_00_00"
CODEC_SUITE_NAME="${WORKDIR}/${PN}_${PV}"
@@ -27,7 +28,6 @@ SRC_URI="http://software-dl.ti.com/dsps/dsps_public_sw/codecs/OMAP35xx//OMAP35xx
http://software-dl.ti.com/dsps/dsps_public_sw/codecs/C64XPlus_Speech//C64XPlus_Speech_latest/c64xplus_g711_1_12_00_000_production.bin;name=g711 \
http://software-dl.ti.com/dsps/dsps_public_sw/sdo_tii/OMAP35xx_DM37xx_C64xPLUS_Algorithms/01_00_00_07//exports/c64xplus_deinterlacer_01_00_00_07_production.bin;name=i2p \
git://arago-project.org/git/projects/codec-servers.git;protocol=git \
-
"
SRC_URI[h264enc.md5sum] = "4a7a4698b1db360fe103aae76127a4ec"
diff --git a/recipes/ti/ti-dmai.inc b/recipes/ti/ti-dmai.inc
index c3a0f710d1..a5a11a1756 100644
--- a/recipes/ti/ti-dmai.inc
+++ b/recipes/ti/ti-dmai.inc
@@ -27,6 +27,10 @@ SRC_URI = "svn://gforge.ti.com/svn/dmai/;module=${DMAIBRANCH};proto=https;user=a
file://loadmodules-ti-dmai-ol138_al.sh \
file://doxygen_templates.tar.gz \
file://arago-tdox \
+ file://beagle/0001-DMAI-video_display-Set-the-default-Display-Output-to.patch \
+ file://beagle/0002-DMAI-Auto-detect-V4L2-display-device-node-to-open.patch \
+ file://beagle/0003-DMAI-Disable-display-rotation-to-avoid-problems-due-.patch \
+ file://beagle/0004-DMAI-Use-the-correct-capture-device-node.patch \
"
DEPENDS = "virtual/kernel alsa-lib ti-framework-components ti-codec-engine ti-xdctools"
diff --git a/recipes/ti/ti-dmai/beagle/0001-DMAI-video_display-Set-the-default-Display-Output-to.patch b/recipes/ti/ti-dmai/beagle/0001-DMAI-video_display-Set-the-default-Display-Output-to.patch
new file mode 100644
index 0000000000..fce8272962
--- /dev/null
+++ b/recipes/ti/ti-dmai/beagle/0001-DMAI-video_display-Set-the-default-Display-Output-to.patch
@@ -0,0 +1,26 @@
+From c584fc4593fc95c24facc8521a8a1180a0bc7b13 Mon Sep 17 00:00:00 2001
+From: Joel <joel@chase-ubuntu.(none)>
+Date: Mon, 20 Jun 2011 16:59:54 -0500
+Subject: [PATCH 1/4] DMAI video_display: Set the default Display Output to DVI.
+
+Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com>
+---
+ apps/video_display/linux/main.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+packages/ti/sdo/dmai
+diff --git a/packages/ti/sdo/dmai/apps/video_display/linux/main.c b/packages/ti/sdo/dmai/apps/video_display/linux/main.c
+index 15182b7..496d19c 100644
+--- a/packages/ti/sdo/dmai/apps/video_display/linux/main.c
++++ b/packages/ti/sdo/dmai/apps/video_display/linux/main.c
+@@ -45,7 +45,7 @@
+ #include "../appMain.h"
+
+ /* Default arguments for app */
+-#define DEFAULT_ARGS { 1000, FALSE, FALSE, VideoStd_D1_NTSC, Display_Output_COMPOSITE }
++#define DEFAULT_ARGS { 1000, FALSE, FALSE, VideoStd_D1_NTSC, Display_Output_DVI }
+
+ /*
+ * Argument IDs for long options. They must not conflict with ASCII values,
+--
+1.7.0.4
+
diff --git a/recipes/ti/ti-dmai/beagle/0002-DMAI-Auto-detect-V4L2-display-device-node-to-open.patch b/recipes/ti/ti-dmai/beagle/0002-DMAI-Auto-detect-V4L2-display-device-node-to-open.patch
new file mode 100644
index 0000000000..77882f4a25
--- /dev/null
+++ b/recipes/ti/ti-dmai/beagle/0002-DMAI-Auto-detect-V4L2-display-device-node-to-open.patch
@@ -0,0 +1,109 @@
+From 39d909ea1040b86968adf0d62475955bd07f96a8 Mon Sep 17 00:00:00 2001
+From: Joel A Fernandes <agnel.joel@gmail.com>
+Date: Tue, 21 Jun 2011 15:33:14 -0500
+Subject: [PATCH 2/4] DMAI: Auto-detect V4L2 display device node to open.
+
+Changes in display device node names in the kernel break DMAI.
+This autodetects the device node name to avoid such breakages in the future.
+
+Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com>
+---
+ linux/Display.c | 2 +-
+ linux/omap3530/Display_v4l2.c | 40 ++++++++++++++++++++++++++++++++++++++++
+ 2 files changed, 41 insertions(+), 1 deletions(-)
+
+diff --git a/packages/ti/sdo/dmai/linux/Display.c b/packages/ti/sdo/dmai/linux/Display.c
+index bf0db2e..578ab8a 100644
+--- a/packages/ti/sdo/dmai/linux/Display.c
++++ b/packages/ti/sdo/dmai/linux/Display.c
+@@ -197,7 +197,7 @@ const Display_Attrs Display_Attrs_O3530_VID_DEFAULT = {
+ Display_Std_V4L2,
+ VideoStd_VGA,
+ Display_Output_LCD,
+- "/dev/video1",
++ "", // V4L2 device nodes are auto detected
+ 0,
+ ColorSpace_UYVY,
+ -1,
+diff --git a/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c b/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
+index 8cd891c..61f15bb 100644
+--- a/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
++++ b/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
+@@ -35,6 +35,7 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <fcntl.h>
++#include <dirent.h>
+ #include <sys/ioctl.h>
+ #include <sys/mman.h>
+ #include <errno.h>
+@@ -55,6 +56,7 @@
+ #include "priv/_SysFs.h"
+
+ #define MODULE_NAME "Display"
++#define V4LVOUT_DIR "/sys/devices/platform/omap_vout/video4linux"
+
+ /******************************************************************************
+ * cleanup
+@@ -134,6 +136,7 @@ Display_Handle Display_v4l2_create(BufTab_Handle hBufTab, Display_Attrs *attrs)
+ #if defined(V4L2_CID_ROTATE)
+ struct v4l2_control control;
+ #endif
++ char displayDevName[20];
+ assert(attrs);
+
+ /* Allocate space for state object */
+@@ -152,6 +155,13 @@ Display_Handle Display_v4l2_create(BufTab_Handle hBufTab, Display_Attrs *attrs)
+ }
+ hDisplay->userAlloc = TRUE;
+
++ /* Get video capture device */
++ if(Display_v4l2_getdevice(displayDevName) < 0) {
++ Dmai_err0("Failed to get V4L2 display device node.\n");
++ return NULL;
++ }
++ attrs->displayDevice = displayDevName;
++
+ /* Open video capture device */
+ hDisplay->fd = open(attrs->displayDevice, O_RDWR, 0);
+
+@@ -319,6 +329,36 @@ Int Display_v4l2_delete(Display_Handle hDisplay)
+ }
+
+ /******************************************************************************
++ * Display_v4l2_getdevice
++ ******************************************************************************/
++Int Display_v4l2_getdevice(char displayDevice[20])
++{
++ DIR *dp;
++ struct dirent *ep;
++ dp = opendir (V4LVOUT_DIR);
++ displayDevice[0] = '\0';
++ strcat(displayDevice, "/dev/");
++ if (dp != NULL) {
++ while(ep = readdir (dp)) {
++ if(ep->d_name[0] == '.') continue;
++ Dmai_dbg1("V4L Video node found: '%s'\n", ep->d_name);
++ if(strlen(ep->d_name) > 19 - strlen(displayDevice)) {
++ ep = NULL;
++ break;
++ }
++ strcat(displayDevice, ep->d_name);
++ closedir (dp);
++ break;
++ }
++ }
++ if(!dp || !ep) {
++ Dmai_err0("Could not open the directory\n");
++ return -1;
++ }
++ return 0;
++}
++
++/******************************************************************************
+ * Display_v4l2_get
+ ******************************************************************************/
+ Int Display_v4l2_get(Display_Handle hDisplay, Buffer_Handle *hBufPtr)
+--
+1.7.0.4
+
diff --git a/recipes/ti/ti-dmai/beagle/0003-DMAI-Disable-display-rotation-to-avoid-problems-due-.patch b/recipes/ti/ti-dmai/beagle/0003-DMAI-Disable-display-rotation-to-avoid-problems-due-.patch
new file mode 100644
index 0000000000..924e301df3
--- /dev/null
+++ b/recipes/ti/ti-dmai/beagle/0003-DMAI-Disable-display-rotation-to-avoid-problems-due-.patch
@@ -0,0 +1,29 @@
+From 46cb37b4b2efdcc8fb9d2edf8e08a3b0e1c15f80 Mon Sep 17 00:00:00 2001
+From: Joel A Fernandes <agnel.joel@gmail.com>
+Date: Tue, 21 Jun 2011 15:53:32 -0500
+Subject: [PATCH 3/4] DMAI: Disable display rotation to avoid problems due to not passing vrfb in bootargs
+
+Disable display rotation as it is not known to be used by many users and can result
+in problems if vrfb is not passed in bootargs.
+
+Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com>
+---
+ linux/omap3530/Display_v4l2.c | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c b/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
+index 61f15bb..3cfd75d 100644
+--- a/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
++++ b/packages/ti/sdo/dmai/linux/omap3530/Display_v4l2.c
+@@ -174,6 +174,8 @@ Display_Handle Display_v4l2_create(BufTab_Handle hBufTab, Display_Attrs *attrs)
+ return NULL;
+ }
+
++#undef V4L2_CID_ROTATE
++
+ #if defined(V4L2_CID_ROTATE)
+ /* Make rotation by default 0 for DVI and S-video*/
+
+--
+1.7.0.4
+
diff --git a/recipes/ti/ti-dmai/beagle/0004-DMAI-Use-the-correct-capture-device-node.patch b/recipes/ti/ti-dmai/beagle/0004-DMAI-Use-the-correct-capture-device-node.patch
new file mode 100644
index 0000000000..35a404393e
--- /dev/null
+++ b/recipes/ti/ti-dmai/beagle/0004-DMAI-Use-the-correct-capture-device-node.patch
@@ -0,0 +1,26 @@
+From 5e59be7d0d5d3d90e9bbc5d1bb5829ad8482fbf0 Mon Sep 17 00:00:00 2001
+From: Joel A Fernandes <agnel.joel@gmail.com>
+Date: Fri, 24 Jun 2011 17:04:10 -0500
+Subject: [PATCH 4/4] DMAI: Use the correct capture device node.
+
+Signed-off-by: Joel A Fernandes <agnel.joel@gmail.com>
+---
+ linux/Capture.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/packages/ti/sdo/dmai/linux/Capture.c b/packages/ti/sdo/dmai/linux/Capture.c
+index e7a081e..a2614e7 100644
+--- a/packages/ti/sdo/dmai/linux/Capture.c
++++ b/packages/ti/sdo/dmai/linux/Capture.c
+@@ -120,7 +120,7 @@ const Capture_Attrs Capture_Attrs_OMAP3530_DEFAULT = {
+ -1,
+ -1,
+ -1,
+- "/dev/video0",
++ "/dev/video2",
+ FALSE,
+ VideoStd_AUTO,
+ -1,
+--
+1.7.0.4
+
diff --git a/recipes/ti/ti-dmai_svn.bb b/recipes/ti/ti-dmai_svn.bb
index 374acce792..f2cb3f8c99 100644
--- a/recipes/ti/ti-dmai_svn.bb
+++ b/recipes/ti/ti-dmai_svn.bb
@@ -9,7 +9,7 @@ PV = "2_10_00_01+svnr${SRCPV}"
# This package has high dependence on kernel, use kernel PR as base and append a local version
PR = "${MACHINE_KERNEL_PR}"
-PR_append = "n"
+PR_append = "p"
DMAIBRANCH_dm6446 = "trunk"
DMAIBRANCH_dm6467 = "branches/GITPSP_INT_101009"
diff --git a/recipes/ti/ti-ipc_1.23.02.27.bb b/recipes/ti/ti-ipc_1.23.02.27.bb
new file mode 100644
index 0000000000..2176b13696
--- /dev/null
+++ b/recipes/ti/ti-ipc_1.23.02.27.bb
@@ -0,0 +1,9 @@
+require ti-ipc.inc
+
+LIC_FILES_CHKSUM = "file://ipc_1_23_02_27_manifest.html;md5=74cbdd9a526809df81e080f19b36eec7"
+
+PV = "1_23_02_27"
+
+SRC_URI[ipcbin.md5sum] = "8c45f6a81cef62f9717335911ee1c9cd"
+SRC_URI[ipcbin.sha256sum] = "b16f29ef016819fe0632468e2f756e05508143cbc732bcaabd269571163b568e"
+
diff --git a/recipes/ti/ti-msp430-chronos_1.05.00.00.bb b/recipes/ti/ti-msp430-chronos_1.05.00.00.bb
index 3455697f19..b5fb130a7c 100644
--- a/recipes/ti/ti-msp430-chronos_1.05.00.00.bb
+++ b/recipes/ti/ti-msp430-chronos_1.05.00.00.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "eZ430 Chronos Tools - MSP430 Development Kit/Watch"
HOMEPAGE = "http://processors.wiki.ti.com/index.php/EZ430-Chronos"
-LICENCE = "unknown"
+LICENSE = "unknown"
SECTION = "multimedia"
PV = "1_05_00_00"
diff --git a/recipes/ti/ti-syslink.inc b/recipes/ti/ti-syslink.inc
new file mode 100644
index 0000000000..bbbf0b307e
--- /dev/null
+++ b/recipes/ti/ti-syslink.inc
@@ -0,0 +1,241 @@
+DESCRIPTION = "SYSLINK Inter-Processor Communications (IPC) for TI ARM/DSP processors"
+HOMEPAGE = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/syslink/index.html"
+SECTION = "devel"
+LICENSE = "BSD"
+
+LIC_FILES_CHKSUM = "file://docs/bsd.pdf;md5=9f2edd962cd129f8c24e9ef1bd641029"
+
+# TODO :: multi-machine, add m3 build as well?
+# TODO :: proper staging?
+# TODO :: kernel module examples?
+# TODO :: smarter handling of config.bld
+# TODO :: review XDC parallel make - why not happening automatically?
+# TODO :: smarter suffix management
+
+require ti-paths.inc
+require ti-staging.inc
+
+PROVIDES = "ti-syslink-module"
+PROVIDES += "ti-syslink-examples"
+
+# This package builds a kernel module, use kernel PR as base and append a local version
+PR = "${MACHINE_KERNEL_PR}"
+PR_append = "a"
+PVExtra = ""
+
+inherit module pkgconfig
+
+S = "${WORKDIR}/syslink_${PV}${PVExtra}"
+
+SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/syslink/${PV}${PVExtra}/exports/syslink_${PV}${PVExtra}.tar.gz;name=syslinktarball \
+ file://syslink.pc \
+ "
+
+DEPENDS = "ti-sysbios ti-xdctools ti-cgt6x ti-ipc"
+DEPENDS += "virtual/kernel"
+
+#common frameq gateMP heapBufMP heapMemMP knlNotify listMP messageQ notify ringIO ringIO_gpp sharedRegion slaveLoader tilerDaemon
+SYSLINKHLOSSAMPLES = "knlnotify slaveLoader frameq notify"
+#SYSLINKRTOSSAMPLES = "frameq gateMP heapBufMP heapMemMP listMP messageQ notify ringIO ringIO_gpp sharedRegion"
+
+# SOC_FAMILY configuration
+
+SYSLINKPLATFORM_omap3 = "OMAP3530"
+SYSLINKPLATFORM_omapl137 = "OMAPL1XX"
+SYSLINKPLATFORM_omapl138 = "OMAPL1XX"
+SYSLINKPLATFORM_ti816x = "TI81XX"
+SYSLINKPLATFORM_ti814x = "TI81XX"
+SYSLINKPLATFORM ?= "<UNDEFINED_SYSLINKPLATFORM>"
+
+SYSLINKVARIANT_omap3 = "OMAP3530"
+SYSLINKVARIANT_omapl137 = "OMAPL1XX"
+SYSLINKVARIANT_omapl138 = "OMAPL1XX"
+SYSLINKVARIANT_ti816x = "TI816X"
+SYSLINKVARIANT_ti814x = "TI814X"
+SYSLINKVARIANT ?= "<UNDEFINED_SYSLINKVARIANT>"
+
+# COFF/ELF config - omap3 can be coff/elf, omapl only coff, ti816x and ti814x only elf
+
+# this really needs to be a list... in the case of ELF/COFF (and this could use DSPSUFFIX?)
+SYSLINKSUFFIX_omap3 = "x64P"
+SYSLINKSUFFIX_omapl137 = "x674"
+SYSLINKSUFFIX_omapl138 = "x674"
+SYSLINKSUFFIX_ti816x = "xe674"
+SYSLINKSUFFIX_ti814x = "xe674"
+SYSLINKSUFFIX ?= "<UNDEFINED_SYSLINKSUFFIX>"
+
+SYSLINKLOADER_omap3 = "COFF"
+SYSLINKLOADER_omapl137 = "COFF"
+SYSLINKLOADER_omapl138 = "COFF"
+SYSLINKLOADER_ti816x = "ELF"
+SYSLINKLOADER_ti814x = "ELF"
+SYSLINKLOADER ?= "<UNDEFINED_SYSLINKLOADER>"
+
+# Do we really need to configure this? - configured already in config.bld
+XDCTARGETS_omap3 = "ti.targets.C64P"
+XDCTARGETS_omapl137 = "ti.targets.C674"
+XDCTARGETS_omapl138 = "ti.targets.C674"
+# for ti816x and ti814x, we should later also build for ti.targets.arm.elf.M3
+XDCTARGETS_ti816x = "ti.targets.elf.C674 ti.targets.arm.elf.M3"
+XDCTARGETS_ti814x = "ti.targets.elf.C674 ti.targets.arm.elf.M3"
+XDCTARGETS ?= "<UNDEFINED_XDCTARGETS>"
+export XDCTARGETS
+
+# Exported Variable needed by build
+export SYSLINK_ROOT = "${S}/packages/"
+
+export XDCPATH = "${IPC_INSTALL_DIR}/packages;${SYSBIOS_INSTALL_DIR}/packages"
+
+do_configure() {
+ sed -i -e s:@VERSION@:${PV}:g ${WORKDIR}/syslink.pc
+
+ cp ${WORKDIR}/syslink.pc ${S}
+}
+
+do_prepsources () {
+
+ # Prepare the tree for rebuiling - clean and generate interfaces
+ cd ${SYSLINK_ROOT}/ti/syslink
+ ${XDC_INSTALL_DIR}/xdc --jobs=${BB_NUMBER_THREADS} .make -PR .
+ ${XDC_INSTALL_DIR}/xdc --jobs=${BB_NUMBER_THREADS} clean -PR .
+ ${XDC_INSTALL_DIR}/xdc --jobs=${BB_NUMBER_THREADS} .interfaces -PR .
+}
+
+addtask prepsources after do_configure before do_compile
+
+do_compile() {
+ # TODO :: KERNEL_CC, should use for kernel module build?
+ # TODO :: Check the 'unset's
+
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+
+# do_make_scripts
+
+ # Build the gpp (hlos) kernel space
+ cd ${SYSLINK_ROOT}/ti/syslink/utils/hlos/knl/Linux && make \
+ ARCH="${TARGET_ARCH}" \
+ CROSS_COMPILE="${TARGET_PREFIX}" \
+ SYSLINK_PLATFORM="${SYSLINKPLATFORM}" \
+ SYSLINK_VARIANT="${SYSLINKVARIANT}" \
+ SYSLINK_LOADER="${SYSLINKLOADER}" \
+ SYSLINK_PKGPATH="${IPC_INSTALL_DIR}/packages" \
+ KDIR="${STAGING_KERNEL_DIR}"
+
+# # Build the gpp (hlos) kernel space samples.
+# for sample in ${SYSLINKHLOSSAMPLES}; do
+# cd ${SYSLINK_ROOT}/ti/syslink/samples/hlos/$sample/knl/Linux && make \
+# ARCH="${TARGET_ARCH}" \
+# CROSS_COMPILE="${TARGET_PREFIX}" \
+# SYSLINK_PLATFORM="${SYSLINKPLATFORM}" \
+# SYSLINK_VARIANT="${SYSLINKVARIANT}" \
+# SYSLINK_LOADER="${SYSLINKLOADER}" \
+# SYSLINK_PKGPATH="${IPC_INSTALL_DIR}/packages" \
+# SYSLINK_SDK=EZSDK \
+# KDIR="${STAGING_KERNEL_DIR}"
+# done
+
+ # Build the gpp (hlos) user space
+ cd ${SYSLINK_ROOT}/ti/syslink/utils/hlos/usr/Linux && make \
+ ARCH="${TARGET_ARCH}" \
+ CROSS_COMPILE="${TARGET_PREFIX}" \
+ TOOLCHAIN_PREFIX="${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}" \
+ SYSLINK_PLATFORM="${SYSLINKPLATFORM}" \
+ SYSLINK_VARIANT="${SYSLINKVARIANT}" \
+ SYSLINK_LOADER="${SYSLINKLOADER}" \
+ SYSLINK_PKGPATH="${IPC_INSTALL_DIR}/packages"
+
+ # Build the gpp (hlos) user space samples
+ # First build the common lib for samples.
+ cd ${SYSLINK_ROOT}/ti/syslink/samples/hlos/common/usr/Linux && make \
+ ARCH="${TARGET_ARCH}" \
+ CROSS_COMPILE="${TARGET_PREFIX}" \
+ TOOLCHAIN_PREFIX="${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}" \
+ SYSLINK_PLATFORM="${SYSLINKPLATFORM}" \
+ SYSLINK_VARIANT="${SYSLINKVARIANT}" \
+ SYSLINK_LOADER="${SYSLINKLOADER}" \
+ SYSLINK_SDK=EZSDK \
+ SYSLINK_PKGPATH="${IPC_INSTALL_DIR}/packages"
+
+ for sample in ${SYSLINKHLOSSAMPLES}; do
+ cd ${SYSLINK_ROOT}/ti/syslink/samples/hlos/$sample/usr/Linux && make \
+ ARCH="${TARGET_ARCH}" \
+ CROSS_COMPILE="${TARGET_PREFIX}" \
+ TOOLCHAIN_PREFIX="${TOOLCHAIN_PATH}/bin/${TARGET_PREFIX}" \
+ SYSLINK_PLATFORM="${SYSLINKPLATFORM}" \
+ SYSLINK_VARIANT="${SYSLINKVARIANT}" \
+ SYSLINK_LOADER="${SYSLINKLOADER}" \
+ SYSLINK_SDK=EZSDK \
+ SYSLINK_PKGPATH="${IPC_INSTALL_DIR}/packages"
+ done
+
+ # Build the dsp/arm (rtos) code (system and samples)
+ # cd ${SYSLINK_ROOT}/ti/syslink && \
+ # ${XDC_INSTALL_DIR}/xdc --jobs=${BB_NUMBER_THREADS} -PR .
+ export XDCOPTIONS=v
+ cd ${SYSLINK_ROOT}/ti/syslink && \
+ ${XDC_INSTALL_DIR}/xdc -P \
+ `${XDC_INSTALL_DIR}/bin/xdcpkg ${SYSLINK_ROOT}/ti/syslink | grep -v samples`
+ export XDCARGS="profile=debug"
+ cd ${SYSLINK_ROOT}/ti/syslink && \
+ ${XDC_INSTALL_DIR}/xdc --jobs=${BB_NUMBER_THREADS} -P \
+ `${XDC_INSTALL_DIR}/bin/xdcpkg ${SYSLINK_ROOT}/ti/syslink | grep samples`
+}
+
+KERNEL_VERSION = "${@base_read_file('${STAGING_KERNEL_DIR}/kernel-abiversion')}"
+
+do_install () {
+
+ # Install the hlos kernel module
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+ install -m 0755 ${SYSLINK_ROOT}/ti/syslink/bin/${SYSLINKVARIANT}/syslink.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/
+
+ # Install the hlos example kernel modules and apps
+ install -d ${D}/${installdir}/ti-syslink-examples
+ install -m 0755 ${SYSLINK_ROOT}/ti/syslink/bin/${SYSLINKVARIANT}/samples/* ${D}/${installdir}/ti-syslink-examples/
+
+ # Install the rtos example apps
+ install -d ${D}/${installdir}/ti-syslink-examples/dsp
+ cd ${SYSLINK_ROOT}/ti/syslink/samples/rtos
+ for i in $(find . -name "*.${SYSLINKSUFFIX}" | grep ${SOC_FAMILY}); do
+ install ${i} ${D}/${installdir}/ti-syslink-examples/dsp/
+ done
+
+ # TODO :: Fixup - library/headers installation - this shouldn't go into the examples directory....
+ # Needs proper staging
+ # Install the library in the filesystem
+ # install -d ${D}/${installdir}/ti-syslink-examples
+ # install -m 0755 ${SYSLINK_ROOT}/ti/syslink/lib/syslink.a ${D}/${installdir}/ti-syslink-examples/
+
+ # Install/Stage the Source Tree
+ install -d ${D}${SYSLINK_INSTALL_DIR_RECIPE}
+ cp -pPrf ${S}/* ${D}${SYSLINK_INSTALL_DIR_RECIPE}
+
+ install -d ${D}/${libdir}/pkgconfig
+ install ${S}/syslink.pc ${D}/${libdir}/pkgconfig/
+}
+
+PACKAGES =+ "ti-syslink-module"
+FILES_ti-syslink-module = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/syslink.ko"
+RDEPENDS_ti-syslink-module += "update-modules"
+
+pkg_postinst_ti-syslink-module () {
+#!/bin/sh
+if [ -n "$D" ]; then
+ exit 1
+fi
+
+depmod -a
+update-modules || true
+}
+
+pkg_postrm_ti-syslink-module () {
+#!/bin/sh
+update-modules || true
+}
+
+PACKAGES =+ "ti-syslink-examples"
+RRECOMMENDS_ti-syslink-examples_append = " ti-syslink-module"
+FILES_ti-syslink-examples = "${installdir}/ti-syslink-examples/*"
+INSANE_SKIP_ti-syslink-examples = True
+
+FILES_ti-syslink-dev = "${libdir}/*"
diff --git a/recipes/ti/ti-syslink/syslink.pc b/recipes/ti/ti-syslink/syslink.pc
new file mode 100644
index 0000000000..c4d720f14b
--- /dev/null
+++ b/recipes/ti/ti-syslink/syslink.pc
@@ -0,0 +1,10 @@
+prefix=/../..//syslink_@VERSION@
+libdir=${prefix}/ti/syslink/lib
+includedir=${prefix}/ti/syslink
+
+Name: TI Syslink
+Description: Syslink ARM-DSP IPC (Inter Processor Communication)
+Version: @VERSION@
+Requires: ipc
+Libs: ${libdir}/syslink.a_release
+Cflags: -I${includedir} -I${includedir}/inc -I${includedir}/utils
diff --git a/recipes/ti/ti-syslink_2.00.00.78.bb b/recipes/ti/ti-syslink_2.00.00.78.bb
new file mode 100644
index 0000000000..71e9621221
--- /dev/null
+++ b/recipes/ti/ti-syslink_2.00.00.78.bb
@@ -0,0 +1,8 @@
+require ti-syslink.inc
+
+PV = "2_00_00_78"
+PVwithdots = "2.00.00.78"
+
+SRC_URI[syslinktarball.md5sum] = "df7c92cd2cca38fdb38e59e4175aba61"
+SRC_URI[syslinktarball.sha256sum] = "3409d080b08ec1d0bd24a715dbec783f1d52020e452485c165ad64e121548ebc"
+
diff --git a/recipes/ti/ti-wifi-utils_git.bb b/recipes/ti/ti-wifi-utils_git.bb
index 96718debdf..9855775c8e 100644
--- a/recipes/ti/ti-wifi-utils_git.bb
+++ b/recipes/ti/ti-wifi-utils_git.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "The calibrator and other useful utilities for TI wireless solution based on wl12xx driver"
-LICENCE = "TI-BSD"
+LICENSE = "TI-BSD"
DEPENDS = "libnl"