aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sqlite/sqlite_2.8.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sqlite/sqlite_2.8.17.bb')
-rw-r--r--recipes/sqlite/sqlite_2.8.17.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/recipes/sqlite/sqlite_2.8.17.bb b/recipes/sqlite/sqlite_2.8.17.bb
index 9f6ec7efe2..5c873d2814 100644
--- a/recipes/sqlite/sqlite_2.8.17.bb
+++ b/recipes/sqlite/sqlite_2.8.17.bb
@@ -4,12 +4,12 @@ SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "readline ncurses"
LICENSE = "PD"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://www.hwaci.com/sw/sqlite/sqlite-${PV}.tar.gz \
file://mainmk_build_dynamic.patch;patch=1 \
file://mainmk_no_tcl.patch;patch=1 \
- file://sqlite.pc"
+ file://sqlite.pc"
SOURCES = "attach.o auth.o btree.o btree_rb.o build.o copy.o date.o delete.o \
expr.o func.o hash.o insert.o main.o opcodes.o os.o pager.o \
@@ -20,6 +20,8 @@ inherit autotools pkgconfig
do_configure() {
echo "main.mk is patched, no need to configure"
+ # make pkgconfig.bbclass pick this up
+ mv ${WORKDIR}/sqlite.pc ${S}
}
do_compile() {
@@ -39,9 +41,6 @@ do_stage() {
ln -sf libsqlite.so.0.8.6 ${STAGING_LIBDIR}/libsqlite.so.0
ln -sf libsqlite.so.0.8.6 ${STAGING_LIBDIR}/libsqlite.so.0.8
install -m 0644 sqlite.h ${STAGING_INCDIR}
-
- # make pkgconfig.bbclass pick this up
- mv ${WORKDIR}/sqlite.pc ${S}
}
do_install() {
@@ -53,9 +52,10 @@ do_install() {
ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so.0.8
install -d ${D}${includedir}
install -m 0644 sqlite.h ${D}${includedir}/sqlite.h
+ install -d ${D}${libdir}/pkgconfig
+ install -m 0644 ${S}/sqlite.pc ${D}${libdir}/pkgconfig/sqlite.pc
}
PACKAGES += "${PN}-bin"
FILES_${PN}-bin = "${bindir}/*"
FILES_${PN} = "${libdir}/*.so.*"
-