aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opkg/opkg-collateral.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opkg/opkg-collateral.bb')
-rw-r--r--recipes/opkg/opkg-collateral.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes/opkg/opkg-collateral.bb b/recipes/opkg/opkg-collateral.bb
index a7ec321c6f..5a0b7835db 100644
--- a/recipes/opkg/opkg-collateral.bb
+++ b/recipes/opkg/opkg-collateral.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "opkg configuration files"
SECTION = "base"
LICENSE = "MIT"
-PR = "r2"
+PR = "r3"
SRC_URI = "file://opkg.conf.comments \
file://lists \
@@ -20,6 +20,11 @@ do_compile_append_shr () {
cat ${WORKDIR}/tmp_dir >>${WORKDIR}/opkg.conf
}
+do_compile_append_angstrom () {
+ cat ${WORKDIR}/tmp_dir >>${WORKDIR}/opkg.conf
+}
+
+
do_install () {
install -d ${D}${sysconfdir}/opkg
install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
@@ -29,4 +34,9 @@ do_install_append_shr () {
install -d ${D}/var/lib/opkg/tmp
}
+do_install_append_angstrom () {
+ install -d ${D}/var/lib/opkg/tmp
+}
+
+PACKAGE_ARCH = "all"
CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"