aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/opensync/libopensync_0.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/opensync/libopensync_0.18.bb')
-rw-r--r--recipes/opensync/libopensync_0.18.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/opensync/libopensync_0.18.bb b/recipes/opensync/libopensync_0.18.bb
new file mode 100644
index 0000000000..5a2e5be2ba
--- /dev/null
+++ b/recipes/opensync/libopensync_0.18.bb
@@ -0,0 +1,18 @@
+SRC_URI = "http://ewi546.ewi.utwente.nl/OE/source/libopensync-${PV}.tar.gz"
+
+
+LICENSE = "LGPL"
+DEPENDS = "sqlite3 libxml2 zlib glib-2.0"
+HOMEPAGE = "http://www.opensync.org/"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-python"
+LEAD_SONAME = "libopensync.so"
+
+FILES_${PN} += " ${libdir}/opensync/formats/*.so"
+
+do_stage() {
+autotools_stage_all
+}
+