aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-projects/om-settings_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openmoko-projects/om-settings_svn.bb')
-rw-r--r--recipes/openmoko-projects/om-settings_svn.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/openmoko-projects/om-settings_svn.bb b/recipes/openmoko-projects/om-settings_svn.bb
new file mode 100644
index 0000000000..579dd3d1be
--- /dev/null
+++ b/recipes/openmoko-projects/om-settings_svn.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Exposure all devices on neo1973"
+DEPENDS = "python-etk python-edbus"
+RDEPENDS = "python-etk python-re python-codecs python-edbus python-pyxdg"
+PV = "0.0.1+svnr${SRCREV}"
+PR = "r3"
+PE = "1"
+
+S = "${WORKDIR}/trunk"
+
+inherit setuptools
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/exposure;module=trunk;proto=http \
+ "
+
+
+PACKAGES = "${PN}"
+FILES_${PN} += "${prefix}/share/* ${sysconfdir}/X11/Xsession.d/*"
+
+pkg_postinst_${PN} () {
+#!/bin/sh
+if test "x$D" = "x"; then
+ killall exposure.py
+ sleep 1
+ exposure.py
+fi
+}