aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/openmoko-3rdparty/rtmom_0.1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/openmoko-3rdparty/rtmom_0.1.3.bb')
-rw-r--r--recipes/openmoko-3rdparty/rtmom_0.1.3.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/openmoko-3rdparty/rtmom_0.1.3.bb b/recipes/openmoko-3rdparty/rtmom_0.1.3.bb
new file mode 100644
index 0000000000..10ab501916
--- /dev/null
+++ b/recipes/openmoko-3rdparty/rtmom_0.1.3.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Elementary based client for Remember the Milk written in Python. "
+AUTHOR = "Michael Pilgermann"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://freshmeat.net/projects/rtmom"
+SRCNAME = "rtmom"
+DEPENDS = "python python-elementary"
+RDEPENDS = "python-core pyrtm"
+RSUGGESTS_${PN} = "python-simplejson"
+
+PACKAGE_ARCH = "all"
+
+PR = "r0"
+
+SRC_URI = "http://cloud.github.com/downloads/kichkasch/rtmom/rtmom-src-${PV}.tar.gz"
+
+FILES_${PN} += "/opt/rtmom \
+ ${datadir}/pixmaps \
+ ${datadir}/applications \
+ ${datadir}/doc/rtmom"
+CONFFILES_${PN} += "/usr/share/doc/${PN}/rtmom.conf.example"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/python ${S}/setup.py build ${D}
+}
+
+do_install() {
+ ${STAGING_BINDIR_NATIVE}/python ${S}/setup.py install ${D}
+ rm -rf ${D}/opt/rtmom/build/
+ rm -rf ${D}/opt/rtmom/patches/
+}