aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/llvm/llvm-gcc4-cross_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/llvm/llvm-gcc4-cross_svn.bb')
-rw-r--r--recipes/llvm/llvm-gcc4-cross_svn.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/llvm/llvm-gcc4-cross_svn.bb b/recipes/llvm/llvm-gcc4-cross_svn.bb
new file mode 100644
index 0000000000..9b0e07ab94
--- /dev/null
+++ b/recipes/llvm/llvm-gcc4-cross_svn.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "The Low Level Virtual Machine - gcc4 frontend"
+HOMEPAGE = "http://llvm.org"
+LICENSE = "various"
+
+DEPENDS = "llvm-native"
+
+PV = "2.1+svnr${SRCREV}"
+
+inherit autotools cross
+
+SRC_URI = "svn://anonsvn.opensource.apple.com/svn/llvm/;module=trunk \
+ "
+
+S = "${WORKDIR}/trunk"
+
+EXTRA_OECONF = "--disable-shared \
+ --enable-llvm=/data/build/koen/OE/build/tmp/angstrom/work/i686-linux/llvm-native-2.0-r0/llvm-2.0 \
+ "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+PARALLEL_MAKE = ""
+
+#oe_runmake gets distracted by GNUMakefiles...
+# we also need to get an install.sh and config-ml.in in gcc/ as well somehow
+do_compile_prepend() {
+ rm -f ${S}/GNUmakefile
+}