aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/i2c-tools/omap3-writeprom.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/i2c-tools/omap3-writeprom.bb')
-rw-r--r--recipes/i2c-tools/omap3-writeprom.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/i2c-tools/omap3-writeprom.bb b/recipes/i2c-tools/omap3-writeprom.bb
new file mode 100644
index 0000000000..485d06fe43
--- /dev/null
+++ b/recipes/i2c-tools/omap3-writeprom.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Writeprom script for omap3 boards with EEPROM on there expansionboard - see http://www.elinux.org/BeagleBoardPinMux#Vendor_and_Device_IDs"
+
+
+SRC_URI = "file://writeprom.sh"
+
+S = "${WORKDIR}"
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 ${WORKDIR}/writeprom.sh ${D}${bindir}/
+}
+
+PACKAGE_ARCH = "all"
+RDEPENDS_${PN} = "i2c-tools"
+FILES_${PN} = "${bindir}"
+