aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/i2c-tools/omap3-writeprom.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2010-04-29 14:41:49 +0200
committerKoen Kooi <koen@openembedded.org>2010-04-29 14:49:12 +0200
commit58fa34bf8aa9719f4dddfaf7d4f03614c1c6bc65 (patch)
tree58f08f1e004c3f261cff1b43610e347f1a56893d /recipes/i2c-tools/omap3-writeprom.bb
parente65d0117079c6399d4b6c648793d7945bfb6b62b (diff)
downloadopenembedded-58fa34bf8aa9719f4dddfaf7d4f03614c1c6bc65.tar.gz
overo-writeprom: rename to omap3-writeprom and make it work on both overo and beagleboard
Diffstat (limited to 'recipes/i2c-tools/omap3-writeprom.bb')
-rw-r--r--recipes/i2c-tools/omap3-writeprom.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/i2c-tools/omap3-writeprom.bb b/recipes/i2c-tools/omap3-writeprom.bb
new file mode 100644
index 0000000000..485d06fe43
--- /dev/null
+++ b/recipes/i2c-tools/omap3-writeprom.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Writeprom script for omap3 boards with EEPROM on there expansionboard - see http://www.elinux.org/BeagleBoardPinMux#Vendor_and_Device_IDs"
+
+
+SRC_URI = "file://writeprom.sh"
+
+S = "${WORKDIR}"
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -m 0755 ${WORKDIR}/writeprom.sh ${D}${bindir}/
+}
+
+PACKAGE_ARCH = "all"
+RDEPENDS_${PN} = "i2c-tools"
+FILES_${PN} = "${bindir}"
+