aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/freerdp/freerdp.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/freerdp/freerdp.inc')
-rw-r--r--recipes/freerdp/freerdp.inc7
1 files changed, 6 insertions, 1 deletions
diff --git a/recipes/freerdp/freerdp.inc b/recipes/freerdp/freerdp.inc
index 0690d6e9ec..10ce13cc8e 100644
--- a/recipes/freerdp/freerdp.inc
+++ b/recipes/freerdp/freerdp.inc
@@ -8,10 +8,15 @@ RDEPENDS_${PN} += "xprop"
SECTION = "x11/network"
LICENSE = "Apache-2.0"
-INC_PR = "r6"
+INC_PR = "r7"
inherit pkgconfig autotools
+do_configure_prepend() {
+ # workaround gcc linking bug
+ find ${S} -name 'Makefile.am' | xargs -n 1 sed 's,-pthread,-lpthread -D_REENTRANT,g' -i
+}
+
do_install_append() {
rm ${D}${libdir}/freerdp/*.a ${D}${libdir}/freerdp/*.la
}