aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/fastcgi
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/fastcgi')
-rw-r--r--recipes/fastcgi/fastcgi_2.4.0.bb5
-rw-r--r--recipes/fastcgi/files/cstdio.patch12
2 files changed, 15 insertions, 2 deletions
diff --git a/recipes/fastcgi/fastcgi_2.4.0.bb b/recipes/fastcgi/fastcgi_2.4.0.bb
index 4c70aa3461..a575da1d84 100644
--- a/recipes/fastcgi/fastcgi_2.4.0.bb
+++ b/recipes/fastcgi/fastcgi_2.4.0.bb
@@ -1,9 +1,10 @@
LICENSE = "Open Market"
DESCRIPTION = "Fast CGI backend (web server to CGI handler) library"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.fastcgi.com/dist/fcgi-${PV}.tar.gz \
-file://link-against-math.patch;patch=1"
+file://link-against-math.patch;patch=1 \
+file://cstdio.patch;patch=1 "
S=${WORKDIR}/fcgi-${PV}
diff --git a/recipes/fastcgi/files/cstdio.patch b/recipes/fastcgi/files/cstdio.patch
new file mode 100644
index 0000000000..90ce2e7e0b
--- /dev/null
+++ b/recipes/fastcgi/files/cstdio.patch
@@ -0,0 +1,12 @@
+Index: fcgi-2.4.0/libfcgi/fcgio.cpp
+===================================================================
+--- fcgi-2.4.0.orig/libfcgi/fcgio.cpp 2009-09-16 23:20:20.504735309 +0200
++++ fcgi-2.4.0/libfcgi/fcgio.cpp 2009-09-16 23:20:34.325635844 +0200
+@@ -23,6 +23,7 @@
+ #endif
+
+ #include <limits.h>
++#include <cstdio>
+ #include "fcgio.h"
+
+ using std::streambuf;