aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/epdfview/epdfview_0.1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/epdfview/epdfview_0.1.7.bb')
-rw-r--r--recipes/epdfview/epdfview_0.1.7.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/recipes/epdfview/epdfview_0.1.7.bb b/recipes/epdfview/epdfview_0.1.7.bb
index 1cd59f7394..fd1b61f7f5 100644
--- a/recipes/epdfview/epdfview_0.1.7.bb
+++ b/recipes/epdfview/epdfview_0.1.7.bb
@@ -5,7 +5,10 @@ SECTION = "x11/applications"
DEPENDS = "poppler gtk+ cups"
SRC_URI = "http://www.emma-soft.com/projects/epdfview/chrome/site/releases/epdfview-${PV}.tar.bz2 \
- "
+ "
+
+SRC_URI_append_shr = "file://acroread.png \
+ "
inherit autotools
@@ -13,3 +16,13 @@ do_compile_append () {
sed -i 's|\$.*prefix./|/usr/|' data/epdfview.desktop
}
+do_compile_append_shr () {
+ sed -i 's/Icon=.*/Icon=acroread/' data/epdfview.desktop
+}
+
+do_install_append_shr () {
+ install -d ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/acroread.png ${D}${datadir}/pixmaps/
+}
+
+FILES_${PN}_append_shr = "${datadir}/pixmaps/acroread.png" \ No newline at end of file