aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/images/console-image.bb20
1 files changed, 3 insertions, 17 deletions
diff --git a/recipes/images/console-image.bb b/recipes/images/console-image.bb
index 9707881402..c3d3f17c39 100644
--- a/recipes/images/console-image.bb
+++ b/recipes/images/console-image.bb
@@ -1,24 +1,10 @@
#Angstrom bootstrap image
+require console-base-image.bb
-IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
-
-ANGSTROM_EXTRA_INSTALL ?= ""
-
-SPLASH ?= ""
-ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
-
-DEPENDS = "task-base-extended \
- ${SPLASH} \
- ${ZZAPSPLASH} \
+DEPENDS += "task-base-extended \
"
-IMAGE_INSTALL = "task-base-extended \
- ${ANGSTROM_EXTRA_INSTALL} \
- ${SPLASH} \
- ${ZZAPSPLASH} \
+IMAGE_INSTALL += "task-base-extended \
"
export IMAGE_BASENAME = "console-image"
-IMAGE_LINGUAS = ""
-
-inherit image