aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/checksums.ini7
-rw-r--r--recipes/compcache/compcache/000-compcache-KERNELDIR.patch34
-rw-r--r--recipes/compcache/compcache/001-compcache-rzscontrol-cross-compile.patch9
-rw-r--r--recipes/compcache/compcache/002-compcache-modules-install.patch13
-rw-r--r--recipes/compcache/compcache/003-compcache-0.6-KERNELDIR.patch31
-rw-r--r--recipes/compcache/compcache_0.5+0.6pre3.bb29
-rw-r--r--recipes/compcache/compcache_0.6.bb27
7 files changed, 150 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 7c0c52d6c8..5c0e4967ce 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -28890,3 +28890,10 @@ sha256=f57c4e33eb2cdd87a6c2f01bfa4794340fbe61ea1a1cfc7dac3b6671e1dd22af
md5=5f7b88ebb2bcd7e8044328482d079661
sha256=f57c4e33eb2cdd87a6c2f01bfa4794340fbe61ea1a1cfc7dac3b6671e1dd22af
+[http://compcache.googlecode.com/files/compcache-0.6pre3.tar.gz]
+md5=532fbc4e6a8ae0670ec15a49484f313f
+sha256=3e54f26665bd1b7ece4e4621a15f82da66a95bafd04286d447be5a596790a7db
+
+[http://compcache.googlecode.com/files/compcache-0.6.tar.gz]
+md5=0a574643c0eb857b946adcd5d5a22eb0
+sha256=e5f697be6c1b7bfb9ac9ba5b8d836ff20f880c161f998c482caba83caf443c0c
diff --git a/recipes/compcache/compcache/000-compcache-KERNELDIR.patch b/recipes/compcache/compcache/000-compcache-KERNELDIR.patch
new file mode 100644
index 0000000000..e80f75b077
--- /dev/null
+++ b/recipes/compcache/compcache/000-compcache-KERNELDIR.patch
@@ -0,0 +1,34 @@
+--- compcache-0.6pre3/Makefile.orig 2009-08-14 00:25:45.904934007 +0800
++++ compcache-0.6pre3/Makefile 2009-08-14 00:25:58.404938574 +0800
+@@ -1,17 +1,17 @@
+ EXTRA_CFLAGS := -DCONFIG_BLK_DEV_RAMZSWAP_STATS \
+ -g -Wall
+
+-ifndef $(KERNEL_BUILD_PATH)
+- KERNEL_BUILD_PATH="/lib/modules/$(shell uname -r)/build"
++ifndef $(KERNELDIR)
++ KERNELDIR="/lib/modules/$(shell uname -r)/build"
+ endif
+
+ obj-m += sub-projects/allocators/xvmalloc-kmod/xvmalloc.o \
+ ramzswap.o
+
+ all:
+- make -C $(KERNEL_BUILD_PATH) \
++ make -C $(KERNELDIR) \
+ M=$(PWD)/sub-projects/allocators/xvmalloc-kmod modules
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD) modules
++ make -C $(KERNELDIR) M=$(PWD) modules
+ make -C sub-projects/rzscontrol
+ @ln -sf sub-projects/allocators/xvmalloc-kmod/xvmalloc.ko
+
+@@ -19,7 +19,7 @@
+ make -C sub-projects/rzscontrol doc
+
+ clean:
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD) clean
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD)/sub-projects/allocators/xvmalloc-kmod clean
++ make -C $(KERNELDIR) M=$(PWD) clean
++ make -C $(KERNELDIR) M=$(PWD)/sub-projects/allocators/xvmalloc-kmod clean
+ make -C sub-projects/rzscontrol clean
+ @rm -rf *.ko
diff --git a/recipes/compcache/compcache/001-compcache-rzscontrol-cross-compile.patch b/recipes/compcache/compcache/001-compcache-rzscontrol-cross-compile.patch
new file mode 100644
index 0000000000..8dbb5909eb
--- /dev/null
+++ b/recipes/compcache/compcache/001-compcache-rzscontrol-cross-compile.patch
@@ -0,0 +1,9 @@
+--- compcache-0.6pre3.orig/sub-projects/rzscontrol/Makefile 2009-08-06 23:27:40.000000000 +0800
++++ compcache-0.6pre3/sub-projects/rzscontrol/Makefile 2009-08-14 00:19:38.374938229 +0800
+@@ -1,5 +1,5 @@
+ all:
+- @gcc -g -Wall -D_GNU_SOURCE rzscontrol.c -o rzscontrol -I ../include -I../..
++ ${CCLD} -g -Wall -D_GNU_SOURCE rzscontrol.c -o rzscontrol -I ../include -I../..
+
+ doc:
+ @xmllint --noout --valid man/rzscontrol.xml
diff --git a/recipes/compcache/compcache/002-compcache-modules-install.patch b/recipes/compcache/compcache/002-compcache-modules-install.patch
new file mode 100644
index 0000000000..cf9b9b12e2
--- /dev/null
+++ b/recipes/compcache/compcache/002-compcache-modules-install.patch
@@ -0,0 +1,13 @@
+--- compcache-0.6pre3/Makefile.orig 2009-08-14 02:33:45.169249060 +0800
++++ compcache-0.6pre3/Makefile 2009-08-14 02:34:15.594938335 +0800
+@@ -13,7 +13,9 @@
+ M=$(PWD)/sub-projects/allocators/xvmalloc-kmod modules
+ make -C $(KERNELDIR) M=$(PWD) modules
+ make -C sub-projects/rzscontrol
+- @ln -sf sub-projects/allocators/xvmalloc-kmod/xvmalloc.ko
++
++modules_install:
++ make -C $(KERNELDIR) M=$(PWD) modules_install
+
+ doc:
+ make -C sub-projects/rzscontrol doc
diff --git a/recipes/compcache/compcache/003-compcache-0.6-KERNELDIR.patch b/recipes/compcache/compcache/003-compcache-0.6-KERNELDIR.patch
new file mode 100644
index 0000000000..98d7e68a5d
--- /dev/null
+++ b/recipes/compcache/compcache/003-compcache-0.6-KERNELDIR.patch
@@ -0,0 +1,31 @@
+--- compcache-0.6/Makefile.orig 2009-08-21 03:15:29.775353453 +0800
++++ compcache-0.6/Makefile 2009-08-21 03:15:49.965346252 +0800
+@@ -1,15 +1,15 @@
+ EXTRA_CFLAGS := -DCONFIG_BLK_DEV_RAMZSWAP_STATS \
+ -g -Wall
+
+-KERNEL_BUILD_PATH ?= "/lib/modules/$(shell uname -r)/build"
++KERNELDIR ?= "/lib/modules/$(shell uname -r)/build"
+
+ obj-m += sub-projects/allocators/xvmalloc-kmod/xvmalloc.o \
+ ramzswap.o
+
+ all:
+- make -C $(KERNEL_BUILD_PATH) \
++ make -C $(KERNELDIR) \
+ M=$(PWD)/sub-projects/allocators/xvmalloc-kmod modules
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD) modules
++ make -C $(KERNELDIR) M=$(PWD) modules
+ make -C sub-projects/rzscontrol
+ @ln -sf sub-projects/allocators/xvmalloc-kmod/xvmalloc.ko
+
+@@ -17,7 +17,7 @@
+ make -C sub-projects/rzscontrol doc
+
+ clean:
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD) clean
+- make -C $(KERNEL_BUILD_PATH) M=$(PWD)/sub-projects/allocators/xvmalloc-kmod clean
++ make -C $(KERNELDIR) M=$(PWD) clean
++ make -C $(KERNELDIR) M=$(PWD)/sub-projects/allocators/xvmalloc-kmod clean
+ make -C sub-projects/rzscontrol clean
+ @rm -rf *.ko
diff --git a/recipes/compcache/compcache_0.5+0.6pre3.bb b/recipes/compcache/compcache_0.5+0.6pre3.bb
new file mode 100644
index 0000000000..7cd29978ff
--- /dev/null
+++ b/recipes/compcache/compcache_0.5+0.6pre3.bb
@@ -0,0 +1,29 @@
+HOMEPAGE = "http://code.google.com/p/compcache"
+DESCRIPTION = "Kernel drivers version 0.6x and related tool for the compcache (compressed in-memory swap device for linux)"
+LICENSE = "GPLv2"
+
+inherit module
+
+SRC_URI = "http://compcache.googlecode.com/files/${PN}-0.6pre3.tar.gz \
+ file://000-compcache-KERNELDIR.patch;patch=1 \
+ file://001-compcache-rzscontrol-cross-compile.patch;patch=1 \
+ file://002-compcache-modules-install.patch;patch=1 \
+ "
+S = "${WORKDIR}/${PN}-0.6pre3"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+PACKAGES = "kernel-module-compcache compcache-utils compcache-utils-dbg compcache-utils-doc"
+
+FILES_kernel-module-compcache = ${FILES_compcache}
+FILES_compcache-utils = "${bindir}/rzscontrol"
+FILES_compcache-utils-dbg = "${bindir}/.debug/rzscontrol"
+FILES_compcache-utils-doc = "${mandir}/man1/rzscontrol.1"
+
+do_install_prepend() {
+ mkdir -p ${D}${bindir}
+ mkdir -p ${D}${mandir}/man1
+ install -m 0755 ${S}/sub-projects/rzscontrol/rzscontrol ${D}${bindir}
+ install -m 0644 ${S}/sub-projects/rzscontrol/man/rzscontrol.1 ${D}${mandir}/man1
+}
+
diff --git a/recipes/compcache/compcache_0.6.bb b/recipes/compcache/compcache_0.6.bb
new file mode 100644
index 0000000000..a24574c703
--- /dev/null
+++ b/recipes/compcache/compcache_0.6.bb
@@ -0,0 +1,27 @@
+HOMEPAGE = "http://code.google.com/p/compcache"
+DESCRIPTION = "Kernel drivers version 0.6x and related tool for the compcache (compressed in-memory swap device for linux)"
+LICENSE = "GPLv2"
+
+inherit module
+
+SRC_URI = "http://compcache.googlecode.com/files/${PN}-${PV}.tar.gz \
+ file://003-compcache-0.6-KERNELDIR.patch;patch=1 \
+ file://001-compcache-rzscontrol-cross-compile.patch;patch=1 \
+ file://002-compcache-modules-install.patch;patch=1 \
+ "
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+PACKAGES = "kernel-module-compcache compcache-utils compcache-utils-dbg compcache-utils-doc"
+
+FILES_kernel-module-compcache = ${FILES_compcache}
+FILES_compcache-utils = "${bindir}/rzscontrol"
+FILES_compcache-utils-dbg = "${bindir}/.debug/rzscontrol"
+FILES_compcache-utils-doc = "${mandir}/man1/rzscontrol.1"
+
+do_install_prepend() {
+ mkdir -p ${D}${bindir}
+ mkdir -p ${D}${mandir}/man1
+ install -m 0755 ${S}/sub-projects/rzscontrol/rzscontrol ${D}${bindir}
+ install -m 0644 ${S}/sub-projects/rzscontrol/man/rzscontrol.1 ${D}${mandir}/man1
+}
+