aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--packages/dtc/dtc_1.1.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/dtc/dtc_1.1.0.bb b/packages/dtc/dtc_1.1.0.bb
new file mode 100644
index 0000000000..933716dcc8
--- /dev/null
+++ b/packages/dtc/dtc_1.1.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "The Device Tree Compiler is a tool used to manipulate the Open-Firmware-like device tree used by PowerPC kernels."
+SECTION = "bootloader"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+DEFAULT_PREFERENCE = "1"
+
+SRC_URI = "http://www.jdl.com/software/dtc-v${PV}.tgz"
+
+S = "${WORKDIR}/dtc-v${PV}"
+
+inherit autotools
+
+do_install() {
+ install -m 0755 -d ${D}${bindir}
+ install -m 755 dtc ${D}${bindir}/dtc
+}