aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/clutter/clutter/workaround-broken-mipmaps.patch13
-rw-r--r--recipes/clutter/clutter_1.2.12.bb1
2 files changed, 14 insertions, 0 deletions
diff --git a/recipes/clutter/clutter/workaround-broken-mipmaps.patch b/recipes/clutter/clutter/workaround-broken-mipmaps.patch
new file mode 100644
index 0000000000..f2a2915958
--- /dev/null
+++ b/recipes/clutter/clutter/workaround-broken-mipmaps.patch
@@ -0,0 +1,13 @@
+--- a/clutter/cogl/pango/cogl-pango-fontmap.c.old 2010-06-08 16:19:26.000000000 +0200
++++ b/clutter/cogl/pango/cogl-pango-fontmap.c 2010-09-06 14:26:07.000000000 +0200
+@@ -173,7 +173,9 @@
+
+ renderer = COGL_PANGO_RENDERER (cogl_pango_font_map_get_renderer (fm));
+
+- _cogl_pango_renderer_set_use_mipmapping (renderer, value);
++ /* disable mipmaps until they are fixed */
++ /* _cogl_pango_renderer_set_use_mipmapping (renderer, value); */
++ _cogl_pango_renderer_set_use_mipmapping (renderer, FALSE);
+ }
+
+ /**
diff --git a/recipes/clutter/clutter_1.2.12.bb b/recipes/clutter/clutter_1.2.12.bb
index a454544c67..fd6247fc5f 100644
--- a/recipes/clutter/clutter_1.2.12.bb
+++ b/recipes/clutter/clutter_1.2.12.bb
@@ -3,6 +3,7 @@ require clutter.inc
PR = "${INC_PR}.1"
SRC_URI = "http://source.clutter-project.org/sources/clutter/1.2/clutter-${PV}.tar.bz2 \
+ file://workaround-broken-mipmaps.patch \
${INC_SRC_URI} \
"