aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes/kexecboot/kexecboot-klibc_git.bb4
-rw-r--r--recipes/kexecboot/kexecboot.inc14
-rw-r--r--recipes/kexecboot/kexecboot_git.bb4
3 files changed, 12 insertions, 10 deletions
diff --git a/recipes/kexecboot/kexecboot-klibc_git.bb b/recipes/kexecboot/kexecboot-klibc_git.bb
index 3cd0849a44..4b70e88373 100644
--- a/recipes/kexecboot/kexecboot-klibc_git.bb
+++ b/recipes/kexecboot/kexecboot-klibc_git.bb
@@ -1,9 +1,9 @@
RDEPENDS_${PN} = "kexec-klibc"
PV = "0.5"
-PR = "r23+gitr${SRCREV}"
+PR = "r24+gitr${SRCREV}"
SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git "
-SRCREV = "92403e305a57154c7c779d6d47600387116a7988"
+SRCREV = "e951750b09eb0e1ba81f1bf71d6108c8d3288f91"
S = "${WORKDIR}/git"
# the binary is statically linked against klibc
diff --git a/recipes/kexecboot/kexecboot.inc b/recipes/kexecboot/kexecboot.inc
index ff5e603183..2a9a63f509 100644
--- a/recipes/kexecboot/kexecboot.inc
+++ b/recipes/kexecboot/kexecboot.inc
@@ -28,15 +28,17 @@ inherit autotools
# [default=no]
# --enable-timeout allow to boot 1st kernel after timeout in seconds
# [default=no]
-# --enable-bpp enable support of specified bpp modes
+# --enable-delay specify delay before device scanning, allowing
+# initialization of old CF/SD cards [default=1]
+# --enable-bpp enable support of specified bpp modes
# (all,32,24,18,16,4,2,1) [default=all]
############################
-EXTRA_OECONF_akita = "--enable-zaurus"
-EXTRA_OECONF_c7x0 = "--enable-zaurus"
-EXTRA_OECONF_spitz = "--enable-zaurus"
-EXTRA_OECONF_poodle = "--enable-zaurus"
-EXTRA_OECONF_tosa = "--enable-zaurus"
+EXTRA_OECONF_akita = "--enable-zaurus --enable-delay=1"
+EXTRA_OECONF_c7x0 = "--enable-zaurus --enable-delay=1"
+EXTRA_OECONF_spitz = "--enable-zaurus --enable-delay=2"
+EXTRA_OECONF_poodle = "--enable-zaurus --enable-delay=1"
+EXTRA_OECONF_tosa = "--enable-zaurus --enable-delay=1"
EXTRA_OECONF_omap3 = "--enable-uimage"
do_configure_prepend () {
diff --git a/recipes/kexecboot/kexecboot_git.bb b/recipes/kexecboot/kexecboot_git.bb
index bb3cc04098..8e90ffd127 100644
--- a/recipes/kexecboot/kexecboot_git.bb
+++ b/recipes/kexecboot/kexecboot_git.bb
@@ -1,9 +1,9 @@
RDEPENDS_${PN} = "kexec"
PV = "0.5"
-PR = "r23+gitr${SRCREV}"
+PR = "r24+gitr${SRCREV}"
SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git "
-SRCREV = "92403e305a57154c7c779d6d47600387116a7988"
+SRCREV = "e951750b09eb0e1ba81f1bf71d6108c8d3288f91"
S = "${WORKDIR}/git"
require kexecboot.inc