aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-18 11:30:43 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-18 11:30:43 +0100
commitd6c55524b1522cd2789f506586a10e729adcb262 (patch)
treec7b229298a115077413df18d6047cac4003cdd19 /recipes
parent09022c90f1b58c9e5362099a235ba286393d5e09 (diff)
downloadopenembedded-d6c55524b1522cd2789f506586a10e729adcb262.tar.gz
Revert "ecore: fix building for uClibc"
This commits breaks non-uclibc builds since it will add an unconditional -liconv This reverts commit 406cd0fee12ad99ba6d6f7d55f743cc4c6697955.
Diffstat (limited to 'recipes')
-rw-r--r--recipes/efl1/ecore.inc3
-rw-r--r--recipes/efl1/ecore/exit_uclibc.patch26
-rw-r--r--recipes/efl1/ecore/iconv.patch35
-rw-r--r--recipes/efl1/ecore_svn.bb23
4 files changed, 11 insertions, 76 deletions
diff --git a/recipes/efl1/ecore.inc b/recipes/efl1/ecore.inc
index 25603087de..4cbbc01774 100644
--- a/recipes/efl1/ecore.inc
+++ b/recipes/efl1/ecore.inc
@@ -1,7 +1,6 @@
DESCRIPTION = "Ecore is the Enlightenment application framework library"
LICENSE = "MIT BSD"
-DEPENDS = "virtual/libiconv curl eet evas tslib \
- libxtst libxcomposite libxinerama libxscrnsaver libxdamage libxrandr libxcursor libxprintutil"
+DEPENDS = "curl eet evas tslib libxtst libxcomposite libxinerama libxscrnsaver libxdamage libxrandr libxcursor libxprintutil"
# optional
# DEPENDS += "directfb libsdl-x11 openssl virtual/libiconv"
PV = "0.9.9.060+svnr${SRCPV}"
diff --git a/recipes/efl1/ecore/exit_uclibc.patch b/recipes/efl1/ecore/exit_uclibc.patch
deleted file mode 100644
index dea010c116..0000000000
--- a/recipes/efl1/ecore/exit_uclibc.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: ecore/src/lib/ecore_con/ecore_con_dns.c
-===================================================================
---- ecore.orig/src/lib/ecore_con/ecore_con_dns.c 2009-11-14 00:12:04.279051754 +0100
-+++ ecore/src/lib/ecore_con/ecore_con_dns.c 2009-11-14 00:14:41.685708230 +0100
-@@ -135,7 +135,7 @@
- write(fd[1], "", 1);
- }
- close(fd[1]);
--# ifdef __USE_ISOC99
-+# if defined(__USE_ISOC99) && !defined(__UCLIBC__)
- _Exit(0);
- # else
- _exit(0);
-Index: ecore/src/lib/ecore_con/ecore_con_info.c
-===================================================================
---- ecore.orig/src/lib/ecore_con/ecore_con_info.c 2009-11-14 00:14:56.056955719 +0100
-+++ ecore/src/lib/ecore_con/ecore_con_info.c 2009-11-14 00:16:40.035696191 +0100
-@@ -243,7 +243,7 @@
- freeaddrinfo(result);
- err = write(fd[1], "", 1);
- close(fd[1]);
--# ifdef __USE_ISOC99
-+# if defined(__USE_ISOC99) && !defined(__UCLIBC__)
- _Exit(0);
- # else
- _exit(0);
diff --git a/recipes/efl1/ecore/iconv.patch b/recipes/efl1/ecore/iconv.patch
deleted file mode 100644
index bd7f20df3f..0000000000
--- a/recipes/efl1/ecore/iconv.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: ecore/configure.ac
-===================================================================
---- ecore.orig/configure.ac 2009-11-13 23:33:16.504742218 +0100
-+++ ecore/configure.ac 2009-11-13 23:41:52.360519091 +0100
-@@ -392,6 +392,7 @@
- ]
- )
-
-+if test "x${LTLIBICONV}" = "x" ; then
- if test "x${have_iconv}" = "xno" ; then
- AC_CHECK_LIB(c, iconv,
- [have_iconv="yes"] )
-@@ -413,6 +414,9 @@
- fi
-
- fi
-+else
-+ have_iconv="yes"
-+fi
- AC_MSG_CHECKING(for explicit iconv link options)
- AC_MSG_RESULT($iconv_libs)
-
-Index: ecore/src/lib/ecore_txt/Makefile.am
-===================================================================
---- ecore.orig/src/lib/ecore_txt/Makefile.am 2009-11-13 23:32:49.374328084 +0100
-+++ ecore/src/lib/ecore_txt/Makefile.am 2009-11-13 23:33:08.383909514 +0100
-@@ -16,7 +16,7 @@
- libecore_txt_la_SOURCES = \
- ecore_txt.c
-
--libecore_txt_la_LIBADD = @iconv_libs@ \
-+libecore_txt_la_LIBADD = @iconv_libs@ $(LTLIBICONV) \
- @EINA_LIBS@
-
- libecore_txt_la_LDFLAGS = -no-undefined @lt_enable_auto_import@ -version-info @version_info@ @ecore_txt_release_info@
diff --git a/recipes/efl1/ecore_svn.bb b/recipes/efl1/ecore_svn.bb
index 5be2dc80f1..b9f01ba8b3 100644
--- a/recipes/efl1/ecore_svn.bb
+++ b/recipes/efl1/ecore_svn.bb
@@ -1,35 +1,32 @@
require ecore.inc
-PR = "r6"
-
-SRC_URI += "file://iconv.patch;patch=1 \
- file://exit_uclibc.patch;patch=1 \
- "
+PR = "r5"
EXTRA_OECONF = "\
--x-includes=${STAGING_INCDIR}/X11 \
--x-libraries=${STAGING_LIBDIR} \
--enable-simple-x11 \
+\
--enable-ecore-txt \
--enable-ecore-config \
+ --disable-ecore-x-xcb \
--enable-ecore-x \
--enable-ecore-job \
+ --disable-ecore-directfb \
+ --disable-ecore-sdl \
--enable-ecore-fb \
--enable-ecore-evas \
--enable-ecore-evas-software-16-x11 \
+ --disable-ecore-evas-x11-gl \
--enable-ecore-evas-xrender \
+ --disable-ecore-evas-dfb \
+ --disable-ecore-evas-sdl \
+ --disable-openssl \
--enable-abstract-sockets \
--enable-ecore-con \
--enable-ecore-ipc \
--enable-ecore-file \
--enable-inotify \
+ --disable-poll \
--enable-curl \
--disable-ecore-desktop \
- --disable-ecore-x-xcb \
- --disable-ecore-directfb \
- --disable-ecore-sdl \
- --disable-ecore-evas-x11-gl \
- --disable-ecore-evas-dfb \
- --disable-ecore-evas-sdl \
- --disable-openssl \
- --disable-poll \
"