aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:08:39 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:21 +0100
commitb953f04d8a06e4e6129fa0b677145967ff0a010e (patch)
tree6ac043677e40b17361aa8ea6aec0df26984f4f06 /recipes
parent4438e093968dc61a1989f9a27aa4b06d6d166a88 (diff)
downloadopenembedded-b953f04d8a06e4e6129fa0b677145967ff0a010e.tar.gz
webkit-efl: new recipe from SHR
Diffstat (limited to 'recipes')
-rw-r--r--recipes/webkit/webkit-efl_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/webkit/webkit-efl_git.bb b/recipes/webkit/webkit-efl_git.bb
new file mode 100644
index 0000000000..42d6fc8c4c
--- /dev/null
+++ b/recipes/webkit/webkit-efl_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = " Webkit browser engine, EFL edition"
+LICENSE = "GPL"
+PV="0.1+gitr${SRCREV}"
+PR="r1"
+
+DEPENDS = "icu flex gst-plugins-base gstreamer jpeg libpng libxml2 pango \
+ libsoup-2.4 eina ecore evas edje cairo fontconfig freetype curl \
+ sqlite3 libxslt gperf-native libxt"
+
+SRC_URI = "git://gitorious.org/webkit-efl/webkit-efl.git;protocol=git;branch=master"
+
+S= "${WORKDIR}/git"
+
+inherit autotools lib_package pkgconfig
+
+EXTRA_OECONF = "--disable-video --host=${TARGET_SYS} --with-port=efl --enable-web-workers=no"
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES =+ "${PN}-webinspector"
+FILES_${PN}-webinspector = "${datadir}/webkit-1.0/webinspector/"