aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 14:06:56 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-19 08:51:19 +0100
commita070023d0d3c1af845dd41703a8419af818d70f3 (patch)
treeea9d656076d849deb73d1be92fc64c60475f6855 /recipes
parenta7a02936e7aa300b3518152ee34b8721ef14e9d9 (diff)
downloadopenembedded-a070023d0d3c1af845dd41703a8419af818d70f3.tar.gz
python: force reconf for libffi subdirectory, needed with newer autotools
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/python/python_2.6.2.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes/python/python_2.6.2.bb b/recipes/python/python_2.6.2.bb
index 941f039af7..c367ce87c5 100644
--- a/recipes/python/python_2.6.2.bb
+++ b/recipes/python/python_2.6.2.bb
@@ -33,6 +33,10 @@ inherit autotools
TARGET_CC_ARCH_append_armv6 = " -D__SOFTFP__"
TARGET_CC_ARCH_append_armv7a = " -D__SOFTFP__"
+do_configure_prepend() {
+ autoreconf -Wcross --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || oenote "_ctypes failed to autoreconf"
+}
+
#
# Copy config.h and an appropriate Makefile for distutils.sysconfig,
# which laters uses the information out of these to compile extensions