aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2011-03-13 22:47:18 +0100
committerPetr Štetiar <ynezz@true.cz>2011-05-08 19:57:02 +0200
commit9bfd0836bbea1d8200e462add2f7079d2fefbcca (patch)
treedf35705e5f06cc53361a8dde9a31d1d7570add46 /recipes
parent3f644fb436fb78602f59c24769558deb12ab3ed5 (diff)
downloadopenembedded-9bfd0836bbea1d8200e462add2f7079d2fefbcca.tar.gz
lua-lanes: add recipe for git version 2.1.0 and delete the old one
I'm removing the old version 2.0.6, because it shouldn't have been commited at the first place anyway. It was quite buggy and untested version. - renamed package name and use it as git version from now, because they do not tag it so frequently - fix homepage URL to the maintained version - added license checksum Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'recipes')
-rw-r--r--recipes/lua/lua-lanes-2.0.6/0001-fix-LanesTimer-inifinite-thread-GC.patch31
-rw-r--r--recipes/lua/lua-lanes/makefile.patch (renamed from recipes/lua/lua-lanes-2.0.6/makefile.patch)0
-rw-r--r--recipes/lua/lua-lanes/uclibc.patch (renamed from recipes/lua/lua-lanes-2.0.6/uclibc.patch)0
-rw-r--r--recipes/lua/lua-lanes_git.bb (renamed from recipes/lua/lua-lanes_2.0.6.bb)18
4 files changed, 9 insertions, 40 deletions
diff --git a/recipes/lua/lua-lanes-2.0.6/0001-fix-LanesTimer-inifinite-thread-GC.patch b/recipes/lua/lua-lanes-2.0.6/0001-fix-LanesTimer-inifinite-thread-GC.patch
deleted file mode 100644
index 18fb36bbbd..0000000000
--- a/recipes/lua/lua-lanes-2.0.6/0001-fix-LanesTimer-inifinite-thread-GC.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 69583ec6fc6cd18a0248d1233193bb2407dbda04 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
-Date: Sun, 31 Oct 2010 23:02:49 +0100
-Subject: [PATCH] fix LanesTimer inifinite thread GC
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-threading.c 394: pthread_cond_destroy(ref) failed, 16 EBUSY
-
-Signed-off-by: Petr Štetiar <ynezz@true.cz>
----
- src/lanes.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/src/lanes.c b/src/lanes.c
-index c02c540..54cfa7a 100644
---- a/src/lanes.c
-+++ b/src/lanes.c
-@@ -1559,7 +1559,7 @@ LUAG_FUNC( thread_gc ) {
-
- // We can read 's->status' without locks, but not wait for it
- //
-- if (s->status < DONE) {
-+ if (s->status < DONE && strcmp(s->threadName, "LanesTimer")) {
- //
- selfdestruct_add(s);
- assert( s->selfdestruct_next );
---
-1.7.0.4
-
diff --git a/recipes/lua/lua-lanes-2.0.6/makefile.patch b/recipes/lua/lua-lanes/makefile.patch
index 6807010994..6807010994 100644
--- a/recipes/lua/lua-lanes-2.0.6/makefile.patch
+++ b/recipes/lua/lua-lanes/makefile.patch
diff --git a/recipes/lua/lua-lanes-2.0.6/uclibc.patch b/recipes/lua/lua-lanes/uclibc.patch
index b3d1f833c1..b3d1f833c1 100644
--- a/recipes/lua/lua-lanes-2.0.6/uclibc.patch
+++ b/recipes/lua/lua-lanes/uclibc.patch
diff --git a/recipes/lua/lua-lanes_2.0.6.bb b/recipes/lua/lua-lanes_git.bb
index dc9a60d277..06ac3d5cf3 100644
--- a/recipes/lua/lua-lanes_2.0.6.bb
+++ b/recipes/lua/lua-lanes_git.bb
@@ -1,16 +1,19 @@
DESCRIPTION = "Lua Lanes is a Lua extension library providing the possibility to run multiple Lua states in parallel."
+HOMEPAGE = "https://github.com/LuaLanes/lanes"
LICENSE = "MIT"
-HOMEPAGE = "http://kotisivu.dnainternet.net/askok/bin/lanes/index.html"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=8cd4045dac80d5036b8a09fed113236e"
DEPENDS += "lua5.1-native"
RDEPENDS_${PN} += "lua5.1"
-PR = "r1"
-S = "${WORKDIR}/lanes-${PV}"
+PR = "r0"
+PV = "2.1.0+gitr${SRCREV}"
-SRC_URI = "http://luaforge.net/frs/download.php/4652/lanes-2.0.6.tgz \
+S = "${WORKDIR}/git/"
+SRCREV = "507e02b20f4ce2c57c18992fe68430b0ffb3eee9"
+
+SRC_URI = "git://github.com/LuaLanes/lanes.git;protocol=git \
file://makefile.patch \
- file://0001-fix-LanesTimer-inifinite-thread-GC.patch \
"
UCLIBC_PATCHES = "file://uclibc.patch"
@@ -26,8 +29,5 @@ FILES_${PN}-dbg = "${LUA_LIB_DIR}/.debug/lua51-lanes.so"
EXTRA_OEMAKE = "MYFLAGS='${CFLAGS} ${LDFLAGS}'"
do_install() {
- oe_runmake install DESTDIR='${D}/usr'
+ oe_runmake install DESTDIR='${D}/usr'
}
-
-SRC_URI[md5sum] = "1716bdf138fcc65b7069aaad864da677"
-SRC_URI[sha256sum] = "7b07fa1c21749981ec0addcf8e9e85acfca91efe8d3f64982a6ac0bc6a615e70"