aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-12-22 21:46:18 +0100
committerKoen Kooi <koen@openembedded.org>2009-12-22 22:59:11 +0100
commit9a242b73195f124ac04eb3caead502edd422c9fb (patch)
treec75dba4f2e39f7989ba3b194da37c91d06ea1de9 /recipes
parent3bec01ab5fc85b801d65669feded96a1b7eee814 (diff)
downloadopenembedded-9a242b73195f124ac04eb3caead502edd422c9fb.tar.gz
xf86-video-omapfb: hack to build against recent xorg
Diffstat (limited to 'recipes')
-rw-r--r--recipes/xorg-driver/xf86-video-omapfb/0001-omapfb-driver-hack-out-dpms-for-xorg-1.7.x.patch51
-rw-r--r--recipes/xorg-driver/xf86-video-omapfb_git.bb1
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes/xorg-driver/xf86-video-omapfb/0001-omapfb-driver-hack-out-dpms-for-xorg-1.7.x.patch b/recipes/xorg-driver/xf86-video-omapfb/0001-omapfb-driver-hack-out-dpms-for-xorg-1.7.x.patch
new file mode 100644
index 0000000000..045691c192
--- /dev/null
+++ b/recipes/xorg-driver/xf86-video-omapfb/0001-omapfb-driver-hack-out-dpms-for-xorg-1.7.x.patch
@@ -0,0 +1,51 @@
+From 7bfdb731125e2bd18975a3a0f35e424076d55366 Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Tue, 22 Dec 2009 21:35:00 +0100
+Subject: [PATCH] omapfb-driver: hack out dpms for xorg 1.7.x
+
+---
+ src/omapfb-driver.c | 7 +++----
+ 1 files changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/src/omapfb-driver.c b/src/omapfb-driver.c
+index a9d5fbc..ef92ce4 100644
+--- a/src/omapfb-driver.c
++++ b/src/omapfb-driver.c
+@@ -41,9 +41,6 @@
+
+ #include "exa.h"
+
+-#define DPMS_SERVER
+-#include <X11/extensions/dpms.h>
+-
+ #include <linux/fb.h>
+
+ /* TODO: we'd like this to come from kernel headers, but that's not a good
+@@ -581,7 +578,7 @@ OMAPFBScreenInit(int scrnIndex, ScreenPtr pScreen, int argc, char **argv)
+ pScreen->SaveScreen = OMAPFBSaveScreen;
+
+ /* Setup DPMS support */
+- xf86DPMSInit(pScreen, OMAPFBDPMSSet, 0);
++ //xf86DPMSInit(pScreen, fbdevHWDPMSSetWeak(), 0);
+
+ #ifdef USE_EXA
+ /* EXA init */
+@@ -723,6 +720,7 @@ static Bool OMAPFBSwitchMode(int scrnIndex, DisplayModePtr mode, int flags)
+ return TRUE;
+ }
+
++#if 0
+ static void
+ OMAPFBDPMSSet(ScrnInfoPtr pScrn, int mode, int flags)
+ {
+@@ -754,6 +752,7 @@ OMAPFBDPMSSet(ScrnInfoPtr pScrn, int mode, int flags)
+ }
+
+ }
++#endif
+
+ void
+ OMAPFBPrintCapabilities(ScrnInfoPtr pScrn,
+--
+1.6.2.4
+
diff --git a/recipes/xorg-driver/xf86-video-omapfb_git.bb b/recipes/xorg-driver/xf86-video-omapfb_git.bb
index cc68163df4..f9dfe31f9a 100644
--- a/recipes/xorg-driver/xf86-video-omapfb_git.bb
+++ b/recipes/xorg-driver/xf86-video-omapfb_git.bb
@@ -7,6 +7,7 @@ PV = "0.1.1+${PR}+gitr${SRCREV}"
PE = "1"
SRC_URI = "git://git.pingu.fi/xf86-video-omapfb.git;protocol=http \
+file://0001-omapfb-driver-hack-out-dpms-for-xorg-1.7.x.patch;patch=1 \
"
S = "${WORKDIR}/git"